Does NOT erase file when using reboot on the scheduler


New Member
Eraser v5.86.1
OS: Windows 2000 SP4

Scheduling Eraser to erase the recycle bin on reboot gives the following error message on startup:
"File not found. Nothing to erase" (and also lists the location of the folder inside the recycle bin).

Solutions Tried:
1) selected the Recycle Bin folder itself to delete
2) selected the folder inside the Recycle Bin to delete (it has a long file name with numbers and -- )

Still get the same warning message "file not found. Nothing to erase" on reboot.

Manually running the scheduled task DOES delete the Recycle Bin files properly.
Also, setting the task from reboot to a day of the week DOES cause the files to be properly deleted when the day and time is reached.

Eraser doesn't delete the files when it is scheduled on a reboot. It gives the message : "File not found. Nothing to erase".

Is there anything else I can do to fix this?

If not, I would suggest a fix for this problem of failure to delete on reboot in a future release of Eraser.
First are there really files in the recycle bin?

Have you checked the sheduler statistics to make sure that the task runs successfully?

Yes, there are files in the recycle bin to delete.

The task runs, that's when the error message is given saying there are no files to delete.

(There is no error message given when the task is run manually OR when the task is set to day and time. The error message is only given when the task is set to reboot.)
How do you schedule the recycle bin to be erased on reboot? People complain about erasing on reboots but I almost always never seem to know how *-)

Under schedule choose reboot, time does not matter.

I re-installed Eraser.
Now, it DOES erase recycle bin when windows starts up. HOWEVER, the statistics for the task show NO activity has taken place.
yes yes - but how do you tell eraser to erase the recycle bin files?

Task Properties

Under Data Tab
Select: Files in folder
Browse to: C:RECYCLER
Check: Subfolders

Under Schedule Tab
Select: Reboot

Follow-Up to my question.

Uninstalled Eraser v5.86.1
Removed all registry entries
Reinstalled Eraser twice (the first install didnt install for some reason)
Made a new task to erase recycle bin on startup (reboot)

On startup, Eraser erased all files, giving a visual report of erasing, but left recycle bin showing itself as full.
And statistics show task scheduler did NOT run.