DOS Window at startup


New Member
I am using Eraser and just updated to version 6.0.6. Since updating , when I start my computer I get a ‘DOS” window opening that shows, on the top “ C:\Program Files\Eraser\eraser.exe” and then in the window itself it says” Unknown Action: -hide . . . . Press enter to continue” and when do press enter, the window closes and does NOT re-appear until I restart my computer. What is this. . . why did I start seeing it when I upgraded to Version 6.0.6.
I’m running Windows XP Professional(in English), Service Pack 3, will all current updates.
I like the security your product provides, but I’m curious about this window at every startup.
I have just deleted Version 6.06 and installed the latest version 6.0.8, and the "problem" or distraction went away.

Have a great day, all !
The main thin was that you didn't uninstall Eraser 5 before installing Eraser 6... but in any case since that's solved, no problem there.
I am getting the same DOS window at startup with my Windows 7. However, I uninstalled Eraser 5 before installing 6.0.8. I have uninstalled and reinstalled, repaired, uninstalled and then searched for and removed all Eraser files I could find that were left behind by the uninstall, but still get the DOS window. How do I get rid of it?
My guess is that something went wrong with the uninstallation of Eraser 5, or (given that this issue has been reported by another user) with the way the Windows Installer dealt with Eraser 6. The only answer I know to problems of this kind is brute force.

Uninstall Eraser 6. Delete any remaining folders (particularly the Eraser 6 folder in %LOCALAPPDATA%), and, if you can, run a Registry cleaner (such as the ones included in CCleaner and the Tweaknow Power Pack, both of which are free). Then, if you can work with the Registry Editor, use it to search for every key and value containing the word 'Eraser', and delete every one that you are sure refers only to the Eraser program. Then reinstall Eraser, to see if that works.

Thanks, David. I found an entry for Eraser 5 buried in the depths of the registry. After deleting it and reinstalling 6.0.8 the DOS window is gone.
Thank you for reporting this. I now understand this particular problem rather better.

woollymammoth said:
Thanks, David. I found an entry for Eraser 5 buried in the depths of the registry. After deleting it and reinstalling 6.0.8 the DOS window is gone.

I encounter the same thing. The reason is that the eraser seems to be starting the command "Erase.exe -hide" everytime it startup. Deleting the command from the registry RUN section will stop it from running but this does not solve the problem at all. This will only solve the problem for current user. If we try to create a new user account from the same machine. The problem will return and we have to delete the registry key again for the current user.

Somehow, eraser is no fully uninstall or somewhere in the registry, eraser program is still telling windows to recreate the commandline for every new user.

Any solution to this?
huuzzuu said:
Any solution to this?
The issue is that Eraser 5 did not fully uninstall. If you search this forum on the term 'brute force', you will find descriptions of how to remove Eraser (both versions) as fully as possible on the machine. This procedure is summarised in the 5th post in this thread.

Removing Eraser will hopefully clear the ground for a clean install of Eraser 6, and the DOS window will not appear.

I think Eraser 5 had the ability to register itself to start up with the user when it starts.. not too sure since it's been a while since I did Eraser 5 code. Try clearing it for the current user, uninstalling Eraser 5 (deleting eraser.exe and Eraser.dll in System32 if necessary) and see if the registry key stops being re-created at log on for new users.

Also, could you check if it's for a new profile account or previously logged-on accounts? If so, it would be a remnant from the last install more than anything else... of which there really is no solution apart from manually deleting the registry keys from all affected users.