Drive reported full by Brother Setup


New Member
The MFL-Admin setup for my multi-function device is telling me the drive is full.
My first suspicions were rights but I've tried everything and haven't solved it.
It did occur to me that I've 'erased' all the free space on this drive once and I'm wondering if that could have done it.

Has anyone ever had this happen?

I did read a bunch of threads and the FAQ but didn't find anything like this.
It's certainly there in a number of threads in the FAQ; start with the one on common Eraser questions; the section you want is quite near the end of the post.

Since you didn't specifically mention a particular post, I assume that you are referring to the problem where Eraser doesn't clean up the temporary files.
That's not my problem. The drive has 30+GB available and there are no temporary directories.

My problem is that there is certainly free space on the drive but a specific installation routine doesn't 'see' it.

And I freely admit that this problem may in no way be related to Eraser. My initial assumption was I had a rights issue for the application but having failed in all attempts to resolve it from that direction, I considered that 'erasing' the free space on the drive in the past might be the cause.
Yes, I was referring to that post and that issue (which arises fairly frequently). Thank you for your clarification.

The Eraser directory you would be looking for would be in the root of the drive, be randomly named and contain randomly named files. I assume that this is what you did not find.

Assuming that Windows Explorer 'sees' the free space, the issue may be with the file system; I suggest that you run a disk check on the affected drive (Windows will probably need to do this on reboot). Check the option to fix any errors. If that doesn't work, a defrag may help; sometimes programs look for contiguous space. Or, unfortunately, it may be a bug in the Brother program.

Yeah, the random directories aren't there.
I'm going to try and run a checkdisk today and see what turns up.
I did a defrag already which didn't resolve the problem.
Personally, I think it's a bug in the way the program wants access to the drive that is causing the problem.
Which will just lead me to another challenge of figuring out how to get the scanner working without using their Admin installation program.
If you did a defrag, the file system is probably OK; defrag will halt if it detects errors.

It's possible that you have a second drive/partition on your computer that is nearly full. I've seen installers copy temp files to secondary drives before, so that may be your cause. I'm not sure, just guessing :p