New Member
I keep getting the following error message when I try to use Eraser:


Erased area = 0 bytes

Cluster tips = 0 bytes

Data written = 0 bytes

Write time = 0.00 s

Error: Erasing the Free Space of a drive requires elevation
Error: Erasing the Free Space of a drive requires elevation
Error: Failed to erase file names from drive C:\, don't know why exactly.

I am using Eraser 5.86 and my operating system is Windows Vista. Please let me know what I can do to fix the problem. Thanks.
I am still getting the same message even when I try to run the program as the administrator. Any suggestions?
I went to User Accounts in Control Panel (Vista) and turned off the User Account Control thus "elevating" me to a higher Administrator status. I erased my unused disc space then turned the account control on after I finished. It worked for me. Gerry
It's interesting. I tried it myself and it does work properly. I did it with UAC on and it is fine. Hm. Keep these reports coming in.

Hi ya,

I had the same problem as the others did on Vista Home premium, but I used your suggested trick (run as admin) and it worked.

Maybe everyone else is using the shell extension? I can't get it to work when right clicking on the hdd/partition to erase, but opening eraser through the start menu and right clicking on 'run as admin' then using the erase on demand works fine.

Is there a way to have eraser start up in this mode?

Okay, I'm able to get eraser to start up in this mode as described above when I need it but, is there a way to start it up as an administrator automatically when Windows Vista boots?

Not currently. Is there a need to?