Entry Point Not Found: GetNativeSystemInfo


New Member
Hey all,

My boss has me clearing the hard-drives of two old CPUs and an old server. I downloaded and ran your program on the old server, and when I double clicked on it I got this error message.

Eraser 6.08.2273.exe - Entry Point not Found
The procedure entry point GetNativeSystemInfo could not be located in the dynamic link library KERNEL32.dll.

I couldn't get it to load anything past that so I searched your forums and found that if you uninstalled, made sure it wasn't running in the backround, restarted your comp and did it again it should work. I did that like 3 times? To no avail.

Today I tried on another computer, thinking it would work on another one. Got the same error message.

I'm working for a small company with a private server and what not. The server computer I tried to clear is....

Microsoft Windows 2000
Version 5.0 - Build 2195: Service Pack 4
x86 Family 6 Model B
Stepping 10 AT/AT Compatible
523,820 KB RAM

And the second computer I used is a...

Microsoft Windows 2000
Service Pack 4
Dell OPTIPLEX GX240 Intel(R) Pentium
(R) 4 CPU 1.70GHz
261,136 KB RAM

I don't know if any of that information is applicable but I had trouble finding model information and such, If you need better info let me know and also how to get it, I googled around but this is all I could find. :/

I'm using the current Eraser version of downloaded from your site. I tried to attached pictures as per instructed on the forum rules thing, but didn't have any compatible programs.

Thanks for any help! Also if you'r program isn't compatible with these computers, any other suggestions would be a life saver!



I can't find eraser running in the task manager, so I can't cancel it there. Its like its never running. Just a small side note
Joel (the programmer) has said that Eraser 6 ought to run on Windows 2000, but XP SP3 is the earliest OS for which it is officially suitable. It does rather seem as though you have a compatibility issue.

The previous version of Eraser (5.88) is available from Sourceforge. You could see if that works. Or you could try DBAN (see companion forum); that should work on older hardware such as yours.

Yes, it would appear that there is a DLL which depends on an XP-only function. I think it would be unlikely that this would be fixed as Win2k (AFAIK) even has extended support discontinued by Microsoft, hence it would be difficult to test it and obtain the necessary fixes.