ERAFEWD folders left behind.


New Member
I have a newly installed windows XP Pro that i just installed eraser on and i left all settings default and turned it on to erase my other 80 gig drive that was pretty much empty then went to sleep. When i woke up (8 hours later) eraser was still not finished and i didn't want it to run while i was installing things so i turned it off. Few minutes went by then i needed to do something with my 80 gig drive and i seen a ton of erafewd folders with files in them on my drive. I have tried to delete them but i am unable to. I read somewhere else on your forum to just turn eraser on and let it do its thing and it will take them all out but i don't have another 8+ hours to wait for that.
I have used eraser a lot for the past month and i have never had it take so long to clear a drive. I have had it clear my 160 gig in less then 4 hours. So how would i get these files off my computer without running this for another 8+ hours?

BTW I do not have a antivirus or a firewall installed yet. The only new program i even have sense the last time i ran eraser before my reinstall is Acronis but i don't have it set to do anything yet.
Re: ERAFEWD files left behind.

IZZO said:
I have used eraser a lot for the past month and i have never had it take so long to clear a drive. I have had it clear my 160 gig in less then 4 hours. So how would i get these files off my computer without running this for another 8+ hours?
I have a 160 Gb drive and it took 1 hr 22 mins two days ago using a single pass including cluster tips.
Are you erasing with more than a single pass? If yes, try the single pass. It is sufficient.
Re: ERAFEWD files left behind.

I used the default settings and just made sure and checked it again and it is only 1 pass. I don't remember how long exactly it took for the 160 i just remember it was done within a few hours. It probably was only about an hour and half also. This 80 gig drive has never given me trouble and i just checked the health on it and its 100%. I really don't know why 1 pass would take more then 8 hours but i just want to get these files off the drive. Theres a crap load of them and they wont delete.

theres folders through ~ERAFEWD.000A to ~ERAFEWD.0599 and thats 1,439 folders there, each one has 3000 files in it. so that means 4,317,000 files total that i can't delete

I tried to run eraser and it froze and it is taking 95% to 99% of my cpu. Guess i will force it close and try again.
Should i just go in to linux and delete these files or maybe use the unlocker program. It wouldn't cause any problems if i delete these files like that would it? I guess ill just wait for some assistance before i make the step of forcefully deleting them.
Regarding the files left behind, it is perfectly safe to delete these. If they are still locked you could try running unlocker on the folder or as you suggested do it in linux.

With the hanging of eraser I'm not too sure what is happening but can you tell us What version of eraser are you using as well as the OS (including patch level).

You could perhaps try wiping the free space with the Cluster tip area and directory entries options turned off as a test. In 5.x this is done in preferences \ Erasing \ unused disk space. It'd also be worth ensuring that the wipe method is set to Pseudorandom Data.
I ran this again last night on my 80 gig it didn't even get as far as it did the night before. It looked like it only got about 30% after 8 hours. Yesterday it was at 90% after 8 hours.

Microsoft Windows XP
Version 2002
Service pack 3

Pentium 4 CPU 3.20 GHz
2.50 GB of RAM

Windows has been fully updated.

Eraser vers 5.86.1

I ran it again with the Cluster tip area and directory entries options turned off, and it said it would take 30 mins and seems to have a pretty good and fast start compared to the last few times; and yes I have always ran it set to Pseudorandom Data with only 1 pass. Before, when running it with these 2 options turned on, it wouldn't even give me a time. Has already got 15% since writing this.
Talking to you in safe mode now.
I am going to be doing a reinstall of Windows.

The last time I ran the eraser to clear the 80 gig drive it worked fine.
It said it would take 30 mins, but I guess that was just the first part. For the second part, it said it would take another 30 mins and all went well with that.
I then tried to run the Unlocker program to delete those 4 million files and it said that it was unable to and asked me if I wanted to have it run the next time I reboot Windows and I said yes. After the restart it booted to the Windows logo but then went to a black screen and stayed there. I waited a few mins but nothing ever happened. I then went in to safe mode tried to find some errors in the Event Viewer but there weren't any errors.

So I tried to uninstall Unlocker just in case that was messing something up, but it had some how already deleted itself. The only files I could find for it was in Program Files. Under Unlocker there was one log file with the info on a few files it needed to delete on the next boot; so I reinstalled Unlocker and then uninstalled it in hopes that it would uninstall what ever else it might have installed the first time that was messing up my boot but the problem still was not fixed. I then tried to boot again and when it asked if I wanted to go in to safe mode I selected the option a few down to boot with last known working Windows boot (or what ever it says) and that didn't help any. I then went back in to safe mode and tried to do a Windows Restore and that also didn't fix anything. Since this is only a few day old install I figured my best bet now was just to reinstall Windows because I don't want to search for the problem anymore.

I don't believe this problem is directly related to Eraser but i wanted you guys to be aware that Unlocker may not be the best fix for this problem. I deleted what was left of those files while in safe mode, so that might be a better solution.
The 100% cpu is probably due to a very evasive bug about how Eraser cleans up compressed files. Compressed files somehow throw Eraser off and leads to crashes and 100% cpu usage occasionally. I can't find the cause, but in any case the code to erase compressed files in v6 has been removed because of this reason (it's unstable, and a few other reasons regarding Vista compatibility.)

I'm a little undecided on this. For most users on XP it works, but otherwise it unreproducibly causes a crash (after 100% cpu utilisation) and does not work for Vista users. I'd remove it if the community wants me to though.