Eraser 5.7 bug ?


New Member
Operating System : XP +SP1

When I try to erase just a single file, it does not work. If I select that file with another file ,i.e. at least two files, both files are successfully erased.

Is this a bug ?
I can't replicate that on WinXP Pro SP1 or WinXP Home SP2.

Is the problem specific to any file type(s)?
I haven't done an exhaustive test but so far my observations are:

Single file erase works with file extension .exe, .tif, .jpg

but single file erase does not work with files ending with extensions .rtf, .com, .txt, .htm, .pdf, .txt, .ini.
What happens is it just removes the archive attribute but does not erase the file.

However, as long as I select more than one file - it doesn't matter what extension they are, the erase works.
I managed to replicate the problem on WinXP SP2. When I repeated the Erase command on the same file, it did erase.

I tried it on several files and the bug seems to occur only with very small files. It may be related to the fact that, in NTFS, small files and directories can be entirely contained within the master file table (MFT) record.
Glad to hear you could replicate similar behaviour.

I tried erasing two pdf files, one at a time. The first file was 80KB and the second was 3.8MB. Neither would be erased on their own, only the archive attribute was cleared, no matter how many times I tried.
If I selected both of them, they were erased first time.
I hadn't thought of looking at the log window - but when I did, it showed the following message when it could not delete the single files:

Failed..... (The process cannot access the file because it is being used by another process)

As far as I know, it is not being used by another process. If so, why can it be erased when I group it with another file ?