Eraser 5.8.7 portable on Windows PE (XP)


New Member
Hi All,
I just encountered an annoying problem, for which I cannot find a fix. In order to totally erase a HD, I am running Windows PE XP (so that the HD's system is not active) and have an USB drive plugged in, so that I can use the portable apps from there. Now I have Eraser 5.8.7 portable on this USB drive and want to erase the unused space on the HD. Whenever I try to change the Eraser preferences (Strg+E) to change it from the "Unused space" deafult 1-pass to another (e.g. Schneier 7 pass), the defaults ("erase files" and "erase unused space") won't change at all. The same goes for the "Erase files" entry: Though I can change the preferred method and click "OK", the changes aren't saved and the defaults show up next time I go to the Preferences.

I already tried to copy the whole Eraser portable folder onto the RAM Drive created by Win PE, but to no avail - same results. I have Admin privilges (of course) in the Win PE environment and already tried to change folder preferences, in case it might be read-only. Unfortunately this had no effect either.

Is there are solution to this, or am I doing something terribly wrong?

Where did you get the Portable edition from? Does an Eraser.ini file appear in the program directory after running it and changing the settings?

I'm having the same problem running Eraser 5.8.7 Portable off of a USB flash drive under Windows XP SP2 (not a PE version). I downloaded the program from the Eraser website. The program did generate an "eraser.ini" file in the Eraser Portable folder; however, there are no settings that appear to me to relate to the "Erasing" settings. The program DOES save the "General" preferences, but not the "Erasing" settings (I'm stuck on 35 passes/file :-/ ).
Strange, I see it happening but we follow the documentation for the necessary Windows API calls. I guess this is one bug which is really too difficult to fix relative to the amount of effort that I think is worth putting in for version 5 (which is to be retired after version 6 is released, which is going to be soon.)
I have the same problem on Vista SP2. No .ini file is created and the changed settings aren't even used for the current session.
Yes, but I will not be fixing it for reasons stated in the previous post.