Eraser 5.86 RC 2

Not open for further replies.


Active Member
RC2 fixes a few problems

  • Missing "Erase Unused Space" message in Explorer context menu
  • Free space erase when non-elevated under Vista results in files scattered all over the AppData folder
  • Some users could erase free space using the first/last 2kb option. The new behaviour (although the option could be selected) would be that NOTHING will happen, and all runs will report it as a failure. The UI could not be changed due to a flaw in the design of the program

This is a RELEASE CANDIDATE, meaning there are bugs, but not major ones. It is significantly more stable than a beta should be, but not production quality yet.

Unified setup:

5.86 will be the last in the 5.x series, as the last few bugs were really painful to fix because of the old code and the multiple add-ons which were not part of the original program resulted in feature creep resulting in pretty unmaintainable code.

And those who use x64 - I believe the new setup allows you to install the x86 version of Eraser in case you have older file managers still in use. Please let me know if the setup does not allow you to do so.

Or if corruption may occur... cos' I don't have an x64 box to test with (as much as I am using a core2... =bad choice during software shopping=)

Still no explorer context menu entries under Vista x64. Recycle Bin context entries are okay. No choice was offered about 32-bit or 64-bit.

Install options are somewhat confusing:

Also a minor cosmetic glitch has existed for some time. Notice the headings for the list. Under the 'Files' tab the color of the heading changes:

Let me know what I can do to help.
Ok I've labeled the setup properly. However I can't fix the headers... because it is not a Windows control and alot of wird stuff has been put in.

I personally have not found any new bugs that have not already been reported.

Running XP Pro SP2.
..."reported" there are new bugs?
No, no new bugs. Just known but unsolvable ones, like the cluster tip area and alternate data stream check boxes changing when you alter the erasing method on the preferences page.

Also the final DLL thing which is more of a feature request than a bug.
Already reported

1. The drive context menu bug still not fixed :(

2. From RC1 comments:

Joel wrote:
agent009 wrote:
A side note: can't the Recycle Bin context menu be implemented through shell extensions (using eraser's current preferences) instead of creating all those items calling eraserl.exe with different parameters? Or for that matter, why can't eraserl.exe use eraser's current preferences if no explicit parameters (-method, -results etc.) specified?
No, because of the poor design and ageing code... they are separate programs (exe files) so to get them working in sync would be copying and pasting code jobs... which is bad practice in that you'll leave your code really susceptible to inconsistency.

I understand that thery are separate exe files. However, imagine eraser settings are stored either in a registy key or in a config file (don't really feel like tracking down the exact location right now). Any reason why eraserl.exe can't read from the same location that eraser.exe though?


if (-method not specified) method = default method from eraser config

insdead of:

if (-method not specified) method = "library"


I understand what you mean about the preferences, and I agree it is counterintuitive. Thing is, we're more concerned with getting bugs fixed (because of a so-called feature freeze), rather than adding features because we are starting to develop version 6.

If you've read around, version 5 is almost a decade old (Win 2000 was THE operating system at that time) and features start coming in from nowhere which according to good programming practice should not be done in the first place.

Eraser 5.86

Hey Joel & Overwriter..

I recently built myself a new computer and Downloaded the 5.86RC2 and (not to much to my surprise with Vista(Vista 64bit)) I got this...

I know 5.85 will be replaced shortly...I will just have to use the 5.84 portable (which works fine :) )

You and Joel are doing a great job and im sure Joel has had it with the 5.8X code :lol:

Heres wishing the NEW Eraser will be issue free :!:

PS...on my old vista 64bit I ran 5.85beta 2 (ran great)
Did you select the correct architecture to install?
I see the same window that FlyingHorse has posted in this forum. Do I install both eraser core files? Cause I did..only thing i unticked was Verify and add recycle bin options
I have tried to install this latest RC2 on Vista x64. I get same error as posted by Blewby on installation.

Please can you tell me how to fix this? Which options should be checked in the first picture posted by FlyinHorse? (I have tried every combination I *think* :oops: )[/img]
Not open for further replies.