Eraser crashes on Win 2k8 R2


New Member

Newbie here. I have attempted installs of Eraser on 2 separate Win 2k8 R2 SP1 servers. The install goes through fine and I'm able to launch the application. I can remove individual files/folders with Eraser, but when I try to run a task to wipe the unused disk space, it crashes. Here is the event log:

Faulting application name: Eraser.exe, version:, time stamp: 0x54b418b5
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x5315a05a
Exception code: 0xe0434352
Fault offset: 0x000000000000940d
Faulting process id: 0x1bf4
Faulting application start time: 0x01d0670c5a812b9c
Faulting application path: C:\Program Files\Eraser\Eraser.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: c2840e16-d2ff-11e4-9e28-005056b802f6

One of the servers have . Net 4.5 and the other have . Net 4.0, but the app crashes on both. I have tried uninstall, reinstalling, removing from Registry. I have also tried rebooting, and removing antivirus. I'm not sure what else I could try.

Finally, I installed version and it is able to do the unused disk space task. So I'm not sure if there is an issue with the latest version and Win 2k8 R2 or not. I was able to perform this task on Win 7.

I'm able to do a workaround with installing the next to latest version, but wanted to point out that there may be an issue with the latest version. Thank you!