Eraser stucked during installation -- related to .NET Framework 4

Ramon Tan

New Member
I have been trying unsuccessfully to install Erase
It keeps hanging with the .NET Framework 4 portion (see attached file).

I tried a lower version,, got the same results.
My laptop is running Win 7 (64-bit) Home premium edition, and I had installed earlier Eraser versions before on the same Win 7 platform.

Any useful tips would be highly appreciated.


  • SnapShot 2016-10-14 at 10.13 PM - ERASER install hangs.PNG
    SnapShot 2016-10-14 at 10.13 PM - ERASER install hangs.PNG
    346.7 KB · Views: 3
Thank you muscas, much appreciated. I did not have the opportunity to implement your two suggestions. By the time I "tried reinstalling again", Windows Updates had already installed .NET Framework 4.5 on my laptop, and that seemed to have made ERASER install successfully. It is now working on my laptop. For what it is worth, the developers may wish to know why installing ERASER hangs if there is no earlier version of .NET. This was my experience and is repeatable. ERASER tries to install its "own" version of .NET, even though the screen that comes up suggests it is "going" to MS for .NET. My sincerest gratitude to you for your response and interest in my post. Best regards, RTan