1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Eraser 6 FAT Directory Entry Erasure Implemented

Discussion in 'Eraser Update Alerts' started by Joel, Sep 29, 2009.

  1. Joel

    Joel New Member

    Hello,

    I'm happy to announce that I've managed to code a FAT directory entry cleaning module for Eraser 6 and should be ready in a couple of hours. I need a bunch of testers who are willing to (potentially) sacrifice their hard drives to let Eraser sanitise. The algorithm is fresh out of the oven and thus really needs testing. If you want to help, reply or PM me. I'll send a binary your way.

    Joel
     
  2. Xanashi

    Xanashi New Member

    Hi Joel,
    I'm very pleased to hear that you manage to implement Fat Dir Entry erasure.
    Been hoping for this implementation for a very long time, so if you can use a tester with only common and/or limited knowledge,
    on how erasure and retrieval of data works, I would be more than willing to sacrifice a drive or two for this purpose.

    Once again, thanks for all your work, it's appreciated!

    - Xanashi
     
  3. Joel

    Joel New Member

    Okay, drop me an email (see my profile); I'll email you tomorrow morning (am quite dead after programming for one full day). The current implementation only works on FAT32, but I think with a bit of work (about an hour or two) I should be able to get it to work with FAT12 and FAT16.

    I'd suggest you back up your data!

    Joel
     
  4. Xanashi

    Xanashi New Member

    Thanks, looking forward to test it.
    Currently, both drives are FAT32, so it will do fine, with any initial testing.

    Already done! :wink:
     
  5. Joel

    Joel New Member

    Oops, looks like it took a little longer than expected. I've spent the morning implementing FAT16 and FAT12. Now the code supports all FAT variants (except exFAT which is... patented unfortunately) I'm running a test now with FAT32 to see if any drive corruption results and I'll fire off the binary when the code is confirmed to work (just to be safe)

    Anyone can help me test FAT16? (and FAT12!)

    Joel
     
  6. slipaway

    slipaway New Member

    Hi Joel, Thanks for all the work you put into Eraser it's much appreciated.
    I admit I got excited when I saw this topic that FAT directory erasure has been implemented in version 6. However, I have done my homework and dug thru the forums trying to find a solution for about 3 days now with no luck.

    Setup:

    Windows Vista 64, Windows XP 32
    8GB of RAM
    FAT32 external hard drive.
    Eraser 5.8.7
    Eraser 5.8.8 beta 1

    As a newb to Eraser I tried to wipe free space from the drive under Vista. I had all boxes checked including a Directory Entry wipe. After the free space wipe it went to directory entry overwrite. The status window showed this operation happening and both bars (current and total) were increasing to 100% in synch, then start a cycle again back at 0% over and over. Eventually I froze up and rebooted, tried it again, and this time watched the process on Task Manager. Eraser was consuming about 8MB of RAM per second, as in a memory leak, nonstop until all RAM was used, yet not erasing anything. I used Recuva to scan the drive again and all the old files were not only still there, but were once again recoverable even after a write-over operation.

    So I came here to do more research and discovered that in fact, you did mention Directory Entry wiping in FAT32 will not work with Vista. I rebooted under XP 32 and tried to do the same thing, with the same result. The free space overwrite took about 85 mins, then on to the Directory Entry wipe, and it is stuck in an endless cycle while consuming RAM until it freezes.

    I read that you said Version 6 will not have FAT32 Directory Entry wipe implemented (until this post), and advised the user to use Version 5.

    So my question is why will it not work at all using Version 5 with XP? I've tried everything I can to get it to work but it won't even permanently overwrite the deleted files. Has anyone confirmed that Version 6 is in fact wiping and deleting FAT32 directory entries as advertised? Is this FAT implementation available with a new RC? Will it work with Vista and XP? I hope in my research here I understood correctly what should work and what shouldn't.

    Thanks again I hope you can find what I am doing wrong so I can get this done!
     
  7. Joel

    Joel New Member

    Yes, For Eraser 6 the code hasn't been released yet (It's in SVN Trunk, you can download and compile it yourself if you really want to); Eraser 5 has this bug reported and I believe I also fixed it in trunk. I'll be releasing new betas soon to address these issues.

    Joel
     
  8. slipaway

    slipaway New Member

    Joel thanks for the quick response.
    So to date, then version 5.8.8 beta 1 does NOT handle the FAT32 directory entries as it should if I understand you, and we need to wait for the next beta, either version 5 or 6 to address this correct? Will it work with Vista as well?
     
  9. Joel

    Joel New Member

    Yes, if you run Eraser as an Administrator.

    Eraser 5's regression was caused by Unicode changes; Eraser 6 didn't have the feature before.
     
  10. slipaway

    slipaway New Member

    Ok thanks Joel. I will look for the beta release with the FAT32 fix! Are we able to subscribe to a mailing list to be notified when you release?
     
  11. Joel

    Joel New Member

    Subscribe to this forum. I'll always post updates here.
     
  12. slipaway

    slipaway New Member

    Thank you.
     
  13. nascent

    nascent New Member

    Thanks for the hard work. It's very much appreciated.
    i think this is one of the most underrated open source projects and have loved and use this for a long time now. Keep up the great work.
     
  14. Joel

    Joel New Member

    Is your disk corrupt?
     
  15. kevin39

    kevin39 New Member

    thanks for the inofrmation
     
  16. GwenStefani

    GwenStefani New Member

    Good share.
     
  17. graneam29

    graneam29 New Member

    Great share!
     

Share This Page