Eraser behavior has changed (Bug?): not properly deleting


New Member
On my Win7 machine the behavior of Eraser has changed (Eraser , such that I am unsure erasure has taken place.

Up until recently, to delete a folder and its contents I did the following:
  1. Right click on the folder and select: Eraser --> Erase
  2. Eraser icon starts to pulse
  3. If I go to the Eraser Schedule window I see the task as running. The folder I am deleting, though, is still listed in the Explorer view.
  4. When the task is completed, the folder is gone (erased!)
However, today when I do the same thing (Right click and select Eraser --> Erase) the following happens:
  1. Right click on the folder and select: Eraser --> Erase
  2. Eraser icon doesn't start pulsing
  3. if I go to the Eraser Schedule window I see the task listed as "Queued for Execution"
  4. If i look for the folder I attempted to delete, it is gone (no longer listed).
  5. If I try to run the 'queued for execution" process I get an error saying the file to delete is not found."
So it appears as if Eraser erased the folder name, but did not erase the files!

I can get it to work as expected by using "Erase Schedule --> New Task, selecting run immediately and selecting the folder I want to delete. Then the icon starts throbbing, and Eraser task is described as running.

So what has happened? Could this be due to changes in Win7 system settings (is not fixed if I run as admin)? Whatever, it is very misleading to users, and should have a different behavior, I am sure!
Re: Eraser behavior has changed (Bug?): not properly deletin

it looks like the erase process crashed - Have you got a virus or malware scanner running on access scanning can cause a lock condition with eraser and the AV trying to compete for the same file pointer -

It will try filling the files with random data according to the wipe protocal you picked - If you still have the files - are their contents erased and just the file pointer remails or are they intact i.e the originals?
Re: Eraser behavior has changed (Bug?): not properly deletin

Yes, there is AV software running - BitDefender I am also running ZoneAlarm firewall 11.0.768.000

The folder is definitely not erased - it contains a 1.7GB data dump that takes several minutes to erase when the process runs properly. And the process is still listed by the task manager: just not consuming any cycles. So if it died it's been restarted.

I've done some more checking and i can successfully use right click -> "Erase" to erase individual files. In that case the throbbing Eraser icon starts up, the system tray has a little popup saying "Erase task started" and the Eraser Schedule Task list says the erase process is running.Then, many minutes later I get the "Eraser task completed" popup from tey system tray.

But it does not work when I use right click --> Erase to try and erase the folder containing that file. In that case I do see the "Erase task started" popup from the system tray, but in this case immediately followed by a "Erase task completed" popup. The folder is now gone from the explorer window - but obviously it isn't deleted, as the task when executed properly takes 10-15 mins....

Disabling bitdefender does not solve the problem.

Some further info. When I use right click --> Erase to erase the folder containing the large file, I do get the little popup off the task manager saying "
Re: Eraser behavior has changed (Bug?): not properly deletin

OK erasing failed again, but this time using the Eraser -> Erase Schedule -> New Task -> Add Data -> erase files in folder (Run Immediately) option. Note I am selecting to erase a folder containing 8 files / 12.8GB of data, so I know the erase process should take a while (probably around an hour) to run.

Actual behavior: Eraser starts and stops within seconds, with a "completed with errors" message. When I look for the folder I tried to erase it is not visible in windows explorer. But clearly Eraser didn't erase the file content, given the elapsed running time.
Expected behavior: Either Eraser completes successfully or Eraser fails but leaves the folder and un-erased files visible to the user.

I am fine if Eraser fails to erase, but it should not delete a folder unless everything contained in that folder has been properly deleted.
Re: Eraser behavior has changed (Bug?): not properly deletin

Yeah it's not working reliably for me either. I've given up on it as there's plenty of alternatives.

A bit odd though, been using Eraser for literally years with zero issues up until the last couple of months.
Re: Eraser behavior has changed (Bug?): not properly deletin

I agree that this is a defect, but I can't diagnose the cause for this new issue: it could be due to a Win 7 OS patch / system change, a conflict with AV software, a change in the way my torrent client saves files; or a change in Eraser itself. I would need guidance to do further diagnosis.

I would be happy to provide the Eraser folks with details of my system configuration, if they wish to try and reproduce the problem.

To my mind I am seeing a critical Eraser defect:

** Eraser should not erase a folder unless it has successfully erased all the files inside the folder.

This defect makes it impossible to use Eraser, since I can't trust that 'disappeared' folder content was actually erased.