Eraser Causes freeze of XP when right clicking

Yes you have found the fix... or helped me SIGNIFICANTLY in resolving the problem. To that I thank you. The fix deals with ATL which is what Eraser uses to install the context menu. I don't know what to do yet, but if you say removing the security update helps then great -- though I don't think it's the wisest thing to do. I'll need time to research this before coming up with a solution.

Once more, a million thanks.
Problem: Explorer-crashing Eraser still in distribution

This "stable" release has been available to crash anyone's OS for 3 months now. Of course, your users could take a chance on the "beta" release, but that doesn't actually fix the problem anyway.

The only way this bug could be more severe is if it stopped Windows from loading at all, or deleted random files. Is this really what you consider "stable"? If nothing else, how about a clear warning that THIS SOFTWARE MAY CRASH WINDOWS EXPLORER?
Re: Problem: Explorer-crashing Eraser still in distribution

Please check the forums before re-posting. There isn't a real solution as yet because I really have great difficulty understanding the crash. I haven't got solutions as yet but am working on it time permitting.

Re: Problem: Explorer-crashing Eraser still in distribution

I know you're working on it. That doesn't help the people who download it in the meantime, like I did a couple months ago before the beta was released. It took me this long to figure out why I had to kill and restart explorer.exe every time I rebooted, and why it was more sluggish than usual after that.

If you're still going to offer this buggy software, at least put a warning up so people will know why their computer keeps crashing.
Re: Problem: Explorer-crashing Eraser still in distribution

It does however seem as though the problem is beyond my control. Some computers seem affected while others are perfectly fine and I have no explanation for that. You are welcome to try 5.7 and see if that works for you.

What I've done now is that I've installed a fresh copy of XP, installed Eraser 6 and .NET Framework 3.5 SP1 and the Visual C++ 2008 SP1 Runtime and installed the ATL patch. No problems there, the extension still works. I'm not going to patch Windows up to today (16 Sept), reboot, and see if the explorer context menu still works. If it does, then I am at a loss of ideas...
MarkReaves said:
My context only contains Winamp, VLC, GPGee and 7-zip added.
I've done the exact same setup - XPSP3, all patches, and the above applications... the context menu does not have problems loading...

In all of your cases can you please list the programs running in the background, eg antivirus software, Windows Defender...

I no longer use Windows so I can't be of anymore help. However here's a thought.

Try a fresh install of XP, update it till most current, then install eraser.

Then try a fresh install of XP, install eraser, then update till most current.

Then try a fresh install of XP, install eraser, then update one update at a time until eraser breaks.

A lot of work but doing the above should show whatever the problem is.
I've done #2 on XP, the plugin still works. Tried #1 on Vista, still works. Time to permute the order, I guess.

If anyone of you who is experiencing this problem is comfortable with using debugging tools please PM me I'll try to debug your computer instead of mine since I can't reproduce it using case #1 and case #2. If installing all updates don't cause the problem I don't know what would.

Sorry for the verboseness of my posts. I thought I'd like to keep you guys updated on my thought processes.

I've checked the Eraser 5 settings and the Eraser 6 settings. Eraser 6 shell extension uses ATL which is affected by the Microsoft update. Eraser 5 does not. For those affected, perhaps they may like to try installing Eraser 6 and see if the shell extension works.

I have had the same problem when using 5.8.7 and 5.8.8 beta1. The fix for me was to disable the eraser shell extension - context menu.

Windows Explorer now works with right clicks.
Are you using any antivirus software? What version of Windows are you using? Is DEP on? Is Windows Defender running?

I don't know if you have solved this problem, but I thought I'd throw a little information at you. I have tried using the updated 588 beta with the same problem reoccuring (I am using Windows 7 x64).

This problem was driving me nuts and I read that the context menus are usually the cause of right click freezes. I tried disabling the eraser context menu in the settings, and while it did indeed remove the menu, it still froze so I assumed eraser was not at fault. I then went on to others including a Scan option for Avast Antivirus. I couldn't disable the menu in the settings so I uninstalled Avast, and the problem went away. When I reinstalled it, the problem returned. I then went to the Avast website, and they were pretty certain that Avast wasn't at fault, and that there was possibly a conflict with another program using a context menu, so I had another look. This time instead of simply disabling Erasers context menu I uninstalled the program itself and the problem disappeared. Again when I reinstalled, the problem returned. I have yet to try the Eraser 6 RC5, however I will let you know about that. I have the freezing with both 587 and 588 beta although the freeze only occurs on the first right click when the PC is switched on. It will be fine on every other right click until the next restart.

I don't know if a conflict with Avast Antivirus has any part to play, although I find it odd that the right click is fine if either one of the two is uninstalled.

(Note: I have since tried Eraser 6 RC5 and the freezing is still occuring)
I decided to follow another posters method in this thread regarding the Visual C++ runtimes. I uninstalled ALL the VC++ runtimes and Eraser then rebooted. I reinstalled Eraser and installed only the x64 core files, and it's working fine with no right click freezing, so I guess the problem is down to the VC++ runtime updates in some form or fashion.
I've installed Avast in my test machine and the context menu entry still works. I had a hunch it was potentially due to DEP (Data Execution Prevention) -- any one of you have that turned on? What CPUs are you using?

Well as far as I know it's on by default, mine is set at Turn on DEP for essential Windows programs and services only. I'm using an Athlon 64 X2 5000+

Whatever Microsoft have done in the VC++ update has broken Erasers context menu from what I can see. As it now stands, I am using Avast & Eraser 5.8.7 together with no issues under the VC++ x64 core files. Now if you wish I could run the VC++ updates to see when it breaks. I'm not a programmer so I can in no way tell you whats breaking it, only when it gets broken. I love the program and really don't want to stop using it so I'm certainly happy to do what I can to help narrow the problem down.

Ok - I've now discovered something that is even more annoying - it's only fixed for one reboot. On the first restart after installing Eraser and the VC++ redist the right click works fine & dandy. Any restart after the first doesn't, and thats WITHOUT any updates installed. Only Eraser & Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.17 are instaled. So it probably has nothing to do with the update after all.
Joel said:
Are you using any antivirus software? What version of Windows are you using? Is DEP on? Is Windows Defender running?

Well I remember when I was having this issue, I was running Avast antivirus, Windows defender wasn't installed or was off, Windows XP and not sure what DEP is so not sure if it was on or off.
I've been messing about with this all day, and from what I can see the problem lies is the Microsoft Visual C++ 2008 Redistributable SP1 - 9.0.30729.17 rather than in the update.

After uninstalling, reinstalling and restarting all day I've found a way that works for me that fixes the problem, and hopefully will for you too.

If you already have eraser installed, then uninstall all the VC Runtimes than starts with Microsoft Visual C++ 2008 Redistributable (you don't need to remove Microsoft Visual C++ 2005 if it's installed)

If you haven't installed Eraser yet, then install it, but cancel the installation of the Microsoft Visual C++ 2008 Redistributable when it starts to install. Again if the2008 Redistributables have already been installed by possibly another program, remove them.

Download the Microsoft Visual C++ 2008 Redistributables and you MUST install them in the order of the links below.

1. Choose the version for your OS 32 bit or 64 bit and install this first

64 bit Version -
32 bit Version -

2. Choose the version for your OS 32 bit (x86) or 64 bit (x64) from the webpage and install this second

Keep this file handy we will be using it again at Step 4

3. Choose the version for your OS 32 bit or 64 bit and install this third

64 bit Version -
32 bit Version -

4. Run the file again that you downloaded at Step 2 (the ATL security Update). You will be given the option to Repair or Uninstall, so select Repair and Next and cary on installing it.

5. Restart you computer and hopefully Eraser will not be freezing anymore on the right click.

I have not tested this on a 32 bit system only 64 bit, but I see no reason why it wouldn't work in either. I can only go by my own system, so although it worked for me, I can't guarantee it will work for you. If however, you found the problem as annoying as me, then you have nothing to lose by trying it other than 10 or 15 minutes.

As to what is causing the problem I don't know, and I'm happy to help continue find out, all I know is this solved it for me.