Eraser corrupted jpg files - all 0KB?


New Member
A few weeks ago, I ran eraser to delete unused space, and the power went out in the middle of the process.

Along with all of the extra files out there cluttering up my C: drive (which I eventually deleted), I found several folders of my photos all corrupted with 0KB as the size.

Thank GOD I had them backed up. I just wrote off the glitch to the power outage.

Then I upgraded to Eraser 5.8.6 and ran it to erase unused disk space.

This time it corrupted SIX folders of my photos. All 0KB in length. Around a thousand photos. Again, I have them backed up, so all is not lost. The only thing that happened during the Eraser run was that my Norton antivirus popped up 2 virus alerts. Could that be the problem?

I'm nervous about running Eraser now. Its a great program, but I can't help but be nervous about what I might forget to backup that might get corrupted. Has anyone else have this problem with JPG files? is there a setting I need to change on Eraser. SHould I have it NOT erase cluster tips?
UPDATE : It appears the virus alerts I got may have been from the feature in Eraser that uses a random dll from somewhere in the computer to overwrite on the last pass. I'm not sure where it got these virus files, perhaps it was on the system restore section of the disk.

Still I'm not sure why my photos are going away when I run Eraser
Did NAV say which viruses they were? I haven't had much experience with NAV cleaning viruses off picture files though I've been using it since 2000 so I can't completely eliminate the possibility that NAV corrupted your photos.

They were:

C:\WINDOWS\SYSTEM32\winskwow.dll (infostealer.Gampass)
C:\WINDOWS\SYSTEM32\winsckdo.dll (infostealer.Lineage)

They are viruses used to steal game passwords for online games.
That one definitely came from elsewhere. Yes Eraser copies a random DLL from system32 as plausible deniability. This will be made optional in v6 though. Has the corruption ceased? Have you done chkdsk to ensure your drive's structures are intact?

I have not run eraser on my home PC since the last corruption.

However I ran it on my work laptop, and THE SAME THING HAPPENED.

This time, it wasn't just pictures, it was all types of files. It seems to be isolated to a single folder and it's subfolders under My Documents. A bunch of files suddenly changed to a size of 0KB. At home, the corrupted photos were also under a folder in My Documents.

It seems to work for others, but since this happened on to me two different PC's, I can't risk using it anymore.

I haven't seen anyone else have this problem but I can't believe it's just me.
I've seen this, too. I ran a free space wipe, and afterward, all the files located within a directory and its subdirectories were suddenly 0 bytes in size. The problem folder was compressed, so I thought maybe there was some conflict between Eraser's cluster tip erase and compressed files. I disabled cluster tip wiping, and haven't had a problem since (after months of daily free space wipes).