Eraser crashes part way through process


New Member
I am using 6.0.7 on Windows 7 Pro (admin account running normally and Run as administrator). I have a schedule set to erase several "files in folder"s and the recycle bin. When the status bar is about 1/3 complete, I get the message "Eraser has stopped working" with the following details. Thoughts?

Stopped working

Problem signature:
Problem Event Name: APPCRASH
Application Name: Eraser.exe
Application Version:
Application Timestamp: 4bbfca0e
Fault Module Name: mscorwks.dll
Fault Module Version: 2.0.50727.4927
Fault Module Timestamp: 4a275a68
Exception Code: c0000005
Exception Offset: 0001daef
OS Version: 6.1.7600.
Locale ID: 1033
This kind of thing with file erasures was common with Eraser 6.0.6, but it's the first time I've encountered it with 6.0.7.

Odd crashes like this can be due to file access problems.Try Erasing the contents of the Recycle Bin on its own. Windows sometimes leaves odd files in the Recycle Bin folder that can cause all kinds of problems. If it crashes with just the Recycle Bin, at least we know that's the problem. On the same basis, please create a task for each element of your problem task in turn, and run these tasks until you identify where the crash is happening. Please tell us which file(s) is/are causing the problem.

If they all run satisfactorily, my attention would then turn to the Task List file. Close Eraser, delete the file (%LOCALAPPDATA%\Eraser 6\Task List.ersx), reopen Eraser, and re-create your problem task.

If you still have problems, please come back. The next stage is to try a development build, which has debug code built in. But try the suggested fixes first.

I started testing each folder to see what in particular caused the crash:
  • The recycle bin worked fine.
    C:\Users\admin\AppData\Local\Mozilla\Firefox\Profiles\be48j27u.default - caused a crash.
    C:\Users\admin\AppData\Local\Temp - ran with errors, completed, and crashed upon trying to view the task log (or opening the task for editing). When run as administrator, it crashed as soon as I told it to run.
    C:\Users\admin\AppData\Local\Thunderbird\Profiles\chsxoinw.default - worked just fine.
    C:\Users\admin\AppData\Roaming\Microsoft\Windows\IECompatCache - worked fine.
    C:\Users\Default\AppData\Local\Microsoft\Windows\Temporary Internet Files - worked fine.
    C:\Users\limited\AppData\Local\Mozilla\Firefox\Profiles\kgbngi6r.default - worked fine.
    C:\Users\limited\AppData\Local\Temp - ran with the following errors (when 'run as administrator', I didn't get any errors):

    • Session: Friday, July 09, 2010 8:44:40 AM
      Friday, July 09, 2010 8:44:40 AM Error Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
      Friday, July 09, 2010 8:44:40 AM Error Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
      Friday, July 09, 2010 8:44:40 AM Error Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
      Friday, July 09, 2010 8:44:40 AM Error Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
    C:\Users\limited\AppData\Local\Thunderbird\Profiles\eyg9gwfm.default - worked fine.
    C:\Users\limited\AppData\Roaming\Microsoft\Windows\IECompatCache - worked fine.

Thank you very much for supporting this necessary software.
Try disabling the Force locked files to be unlocked for erasure setting in the Settings page and re-run Eraser on the files which trip Eraser.
That did it. There seem to be some special considerations for C:\Users\current_user\AppData\Local\Temp and C:\Users\current_user\AppData\Local\Mozilla\Firefox\Profiles\. Those two should be erased on restart and prior to doing anything.

The Temp folder contains a file named FXSAPIDebugLogFile.txt, which refused to be deleted and unless I unchecked the "force locked files to be unlocked for erasure" setting, it caused Eraser to crash. I think it can be removed from a different user account (log off, don't just switch users), that way it won't be in use by Windows (probably have to run as admin).

The Mozilla\Firefox\Profiles (which contains firefox cache data) also crashed Eraser unless I unchecked the same setting. It completed with errors, which seems reasonable, if I tried to run Eraser on it while Firefox was open (hence my suggestion to erase on restart).

Thanks for all the help. I think that solves all of my problems.
I believe I've had similar crashes before, but I always dismissed it as inconclusive. Could you create a Trac ticket for this so I can debug it in future?