Eraser Crashes Repeatedly


New Member
I am using Windows 7, Eraser

I am trying to set up a recurring task, the deletion of my Firefox cache folder. I set it up, then choose run now, the cleaning begins and the progress bar makes it to around 90%, then the program crashes. I have tried again and again but eraser always stops working. I tried uninstalling and reinstalling but the same thing happens every time. Can anyone help?
In my experience, this kind of crash is usually associated with some kind of file system error. So the first port of call is to do a disk check on the system (with the option to fix errors checked), then try again. The disk check will probably need to be performed on reboot.

If that doesn't work, you have the more long-winded option of manually deleting the cache files to the Recycle Bin, and erasing the contents of that. If the files are too large to recycle, manual deletion then erasing the free space is the next option, though not the complete answer unless you disable shadow copying of files first.

Was Firefox running when you did the erase? If so, you'll need to close it before erasing the files. Alternatively, if you'd rather just let those files being used by Firefox remain locked and let Eraser log as an error, you can disable "Force locked files to be unlocked for erasure."