Eraser does not work on Vista - Access Denied


New Member
I installed Eraser v6.0.7.1893 on my Dell PC, running Vista. When I try to erase my recycle bin, erase free space or perform
any erasing function, I get the same error message:

"Session: Wednesday, August 04, 2010 6:20:19 PM Error Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

I've searched the forum and I confirm that I am running as Administrator. I have also unchecked "Force Locked files to be unlocked for
erasure" but it does not make any difference.

What else should I try to fix the problem?

I've had this error, but only with specific files, so I'm a bit unsure about this one.

What OS are you using? Does the error show up in the Task Log? And when you say you are running as Administrator, if your PC runs Vista or Windows 7, did you explicitly run Eraser 'as Administrator'? And, if you did, did you close the already running instance of Eraser before doing so?


I've tried everything on the other thread - I am showing my hidden files and protected system files. I still can't get Eraser to work even once.

I'm on Vista Home Basic SP2.

Any other suggestions?

What are the answers to my questions on running Eraser as Administrator?

same problem - i have an hp machine with vista sp2 also. Eraser seems to work on only the recycle bin not on my hard drives.
Go back to the FAQ post on Getting to know Eraser 6, and make sure you follow fully the instructions for running Eraser as Administrator.