Eraser goes out of control!

>>What changes did you make?
Since the last version none. Just following standard procedure.

I have uploaded a file expand.exe to

This console app will append large amounts of data to a file. I use it for testing.

I suggest running this on one of your problem files and seeing if you can add small amounts first. Expand uses all the same basic functions as eraser and so should behave in the same way. e.g getfilesize etc


The same file enlargement problem occurs with v5.3 too.
Ill have a look at expand.exe and see if I can get it to do anything strange as well. :)

Best wishes,

3 years later . . .

I am using Eraser 5.7 and one of my PCs recently started to show this behavior too. I have never seen it before and I have been using Eraser for over 2 years.

This particular machine is running Win XP SP2.

It does not happen with every file in the Recycling Bin and it does not happen all the time, only with some files, but I haven't spotted any difference so far. If you restore the files back to where they were before being deleted to the Recycling Bin same problem happens so this is not a problem related to the BIN. And I think it is not totally Eraser's problem but another program's that I have might have recently installed. I do not believe it is virus/adware related because I take good care against them.

I wonder if someone ever solved this strange issue.

I will try to reproduce the problem, erasing file by file, to see if I can identify something, like extension, or size.

Will let you know.
Possible solution?

I believe that I solved the issue. Just degragmented the hdd that was badly fragmented.

Add a chkdsk /f before degragmenting just in case.