Eraser has encountered a problem


New Member
I am a first time user of Eraser.
It downloaded and installed fine, but each time I try and run it it says Eraser encountered a problem and needs to close. I have downloaded again and run a repair, but the same thing happens. I am running Windows XP.

Can you suggest a solution please
Yes. Please read the FAQ (link below). You need to read the topics entitled 'Getting to know Eraser 6' (for help to new users), and 'Common Eraser questions' (which tells you how to delete the Task file, which is most likely what you need to do).

Hi David thanks for your help.
I have read the FAQ and now have 2 problems in that the registry key HKCU/software, does not contain an eraser entry, and also the location %USERPROFILE%\Local Settings\Application Data does not contain an Eraser6 folder.
I started again, completely removed Eraser, re-booted the system the re-installed Eraser. It appeared to install perfectly with no errors, but when I run the program I get the Eraser has encountered an error problem. If I right click a file in Explorer and select Eraser/Erase, I get the same error, however in the latter case I also get the attached windows error. The registry key and folder are also still missing.

Regards john.


  • eraser error.jpg
    eraser error.jpg
    52.8 KB · Views: 2,294
This has been reported only a very few times before, and only (I think) with installations on XP. It is clearly the result of a system configuration problem, but the precise cause is, unfortunately, less clear. Eraser does not actually use encrypted data as such, but it does use the RNGCryptoServiceProvider class in .NET to generate pseudorandom data for erasing. I can only guess that something in either the Eraser installation or the .NET installation is failing to access the class properly.

Eraser may work with XP SP2 but the specification states that XP3 is required. I would recommend installing SP3 and fully patching your XP installation if you have not already done so.

Then do a 'brute force' uninstall; uninstall Eraser and manually remove all traces you can find in the file system and the Registry (I search on 'Eraser' and delete all keys and values that appear to be Eraser-specific). If you have ever had Eraser 5 installed on your system, do this for Eraser 5 as well. Then re-download Eraser and reinstall.

If these measures don't work, we shall at least have dealt with the more obvious causes, and the problem will probably be with .NET.

Thanks for your comments.
I run windows XP home SP3 and it is fully patched. To uninstall I use Revo uninstaller.
I un-installed Eraser and then checked the registry and there were no traces of Eraser left there. I then did a clean re-boot of the system so as not to run and unnecessary processes and did a re-install from a new download of Eraser, but as before, the install apparently runs without a hitch, but as soon as I run Eraser it crashes.
Regards Wheelyjon
3 possible causes occur to me.

1. You have a problem with a corrupt task list. You are looking for a file called 'Task List.ersx' in (probably a hidden folder). Unfortunately, I no longer have easy access to an XP machine to check the location of this file under XP. If I got it wrong in my FAQ post, I apologise and would be glad to correct it.

2. Your search missed an Eraser-related value in the Registry. Searching on 'Eraser' and deleting everything (whole keys or individual values) that relates only to Eraser or eraser.exe seems to solve this problem.

3. Something is broken in your .NET installation. That is typically the trickiest one to fix, so I suggest that you have a good go at 1. and 2. first.

Hi David.
1. I have searched all of %userprofile% including all hidden and system files, and the file 'Task List.ersx' does not exist (maybe this is a pointer to the problem?)
2. After uninstalling, I had searched the registry for all occurances of 'Eraser' but none found. I have found that Revo uninstaller is pretty good at getting out bits that are left behind

Although I work on general PC support, I have no experience of .NET problems. Any suggestions ?
Sorry I was a bit slow coming back.

When it decides to give trouble, .NET can be a real pain. The basic advice is to try uninstalling and then reinstalling .NET 3.5 from a direct download. That can have complications of its own. Sometimes there is no uninstall entry for .NET 3.5, and you have to create one by downloading the install file, and installing it over the existing installation. Repair installs may work, but in my experience often don't, so a full uninstall/reinstall gives you the best chance. There is a technique for repairing the install piecemeal, but I'd rather not go down that route unless and until we need to.

Obviously, there is more wide-ranging advice on .NET on other forums also, and (if you can decipher it) on the Microsoft site.

This particular problem indicates there's something wrong with your Windows install -- the Crypto API seems to not be working properly. AFAIK, the only way to resolve this is to do a full system reinstall.
Joel said:
This particular problem indicates there's something wrong with your Windows install -- the Crypto API seems to not be working properly. AFAIK, the only way to resolve this is to do a full system reinstall.

Thanks for that information, windows is working pretty well for everything else and I do not want to do a re-install unless things get really critical. I was going to do a re-install of netframework but have not done it yet. I have another PC which I will try and run eraser on when I want to clear disks.
I think you are probably wise, but my experience with XP is that a full system reinstall would give the machine a new lease of life if it had been used frequently for more than, say, a couple of years. I'm starting to think that the same may be true of Win 7 (nothing could rescue Vista!), but the jury is still out.

I do so (and did so) regardless... XP, Vista, 7... they all speed up after a reinstall. This is especially true if you do not have a good defragmenter (after getting mine I can get by for twice the interval between reinstalls.)
This is old, but I think I've finally fixed the problem. All Eraser 6.0 builds after r2564 have the fix applied and should work. See #406 for details.
I have been using several erasers but wanted to give a try with this one, utterly recommended on the Web. The machine is running XP SP3 re-installed a month ago and since it's a spare one it has basically been sleeping since then. The installation of . NET and Eraser 6 went fine (as far as I can see), but the same "Eraser has encountered a problem, blablabla" displays every time I try to erase a file. As in the case previously mentioned in this forum, I don't have any task scheduled.
If you do have a true solution, kindly let me know. If you just "think it may be this or that", clearly state it, please, and I'll then un-install Eraser and concentrate on others things.
By "true solution" I mean something else re-installing XP!
Thanks in advance.
'Eraser has encountered a problem' is pretty uninformative. 'True' solutions require more information ... :) However, it is pretty clear that you have some sort of installation or setup error.

Which version of Eraser are you using? Have you used more than one version of Eraser (or tried to install Eraser multiple times) on your current Windows installation?

You might also like to try the following (in order) before you reply:
  • using the guidance given in the FAQ (e.g. the sticky 'Common Eraser Questions' topic), find and delete the Task List File (Task List.ersx or Task List.ersy), then re-start Eraser;
  • uninstall Eraser, then reboot before reinstalling.
And also check the HKCU\Software\Eraser\Eraser 6 registry key. If that exists, delete it.

The other possibility is if FIPS compliance is enabled on a Windows XP computer. It's a bug that has been fixed in 6.0.10 (which I should be able to release within the next few days) so you may like to wait for that.