Eraser in Win10?


New Member
Is Eraser compatable with Win10? If so, which build should I be using? I currently have When I try to update from within the program help tab, I get an error message saying that it can't install before the download. I don't see any way to get it to download. When I try to download from here, I get some Social Modules web page instead of a download of eraser.
yes it is

Not on my Windows 10. Hasn't worked since I upgraded to Windows 10. I've installed and uninstalled it too many times to count. Still the same problem, and it doesn't seem as if anyone has attempted to resolve the problem. Try to start it and all you get is that the program has stopped working, Windows tries its troubleshooter with no results, then all you get is an option to close the window. All I ever get from you guys is download the latest version, uninstall and reinstall. How many times do I have to do that before someone realizes that reinstalling the application is not going to fix the problem?
I'm glad for you, but that does not fix it on MY system. Now the question becomes, does anyone out there have a useful solution? Just commenting, "It works here" doesn't provide me with any USEFUL adjustments or tweeks or updates that can be applied to resolve the issue. Nobody out there have a suggestion on where to look within the Windows 10 system that can be manipulated to get Eraser to work here? As I've stated repeatedly, it worked fine UNTIL the Windows 10 update was applied, so the update modified SOMETHING that's causing Eraser to generate the error that's causing it to stop working under Windows 10. Come 0n, any programmers out there that can give an educated guess as to what's the problem?