Eraser keeps erasing the recycle bin


New Member
Even though the recycle bin is erased and empty, when I try to erase the recycle bin again, it seems to erase some files that have been erased before. Eraser does this every time again when I use eraser from the context menu on the recycle bin, instead of doing nothing.
I use Eraser according to the about-box (even though the logo says 6.0.6) on Windows 7 Home Premium - 64.
Is there some file I should delete, or re-install Eraser?

Thanks for any advice.
Windows can leave odd files in the Recycle Bin folder which it protects, so they are almost impossible to remove. If you can, try booting from a non-Windows CD (e.g an Ubuntu install disk), and see if you can use the file manager on that to delete the whole Recycled folder on the target drive. That approach fixed a similar issue for me.

I already managed to get rid of the files in the bin. I remembered that an encryption package I sometimes use (Kyptel) also has a file-shredder. With that I could empty the $Recycle.Bin folder and now Eraser behaves normal again.
That's a relief though, because I've never really worked with Linux, so I really don't know my way around such an OS ;)

Thanks for the advice anyway.

Glad you fixed it. I agree that a Linux boot disk is not necessarily the best answer, but it's the only free option I can think of. As you are an XP user you could possibly also have used Bart PE, but that's rather complex to set up. I usually use a boot disk Created by Acronis True Image (a backup utility), but that's paid for software.

Thanks for the reminder, Joel. I've posted a reference in the 'Index' topic in FAQ.