Eraser not wiping free space


New Member
Hi, having some difficulty here, I've had no problems wiping specific files/folders with Eraser, though now I'm trying to wipe the free space on my drive and it seems to make no progress - I know this tends to take a long time (done it many times before with Eraser), but I have around 300 GB free and after running for 8 hours it looks to be around 5% done, if that. I'm also not seeing any of the temp folders Eraser creates when you're wiping the free space on a drive. Am doing the 3-pass.

My HDD is a 500 GB mechanical drive (non-SSD), I use Windows 7 Ultimate and am using Eraser Any help appreciated. Thanks
It's substantial but something's definitely wrong - I've triple wiped 4 TB drives before and it took maybe a day and a half, I cancelled out the Eraser wipe and tried CCleaner, same thing (triple wipe), it got through only 10 GB in 7 hours - doesn't make any sense, that would mean it would take like a week and a half just to wipe 300 GB, that orders of magnitude slower.

Hopefully this isn't half-assed but my solution right now is to fill the drive with data, wipe the remaining free space which should be tiny, then just delete the copied files.
No, nothing like that. I have an antivirus and firewall running 24/7, and usually am using <10% of the CPU. Nothing suspicious-looking in task manager. Wiping files, even hundreds of GB, works fine, but wiping free space, even on an external drive, eraser will just get to a certain point then hang and never complete.

Any ideas? Thanks
I have the almost the same problem.

I formatted a 1.4tb partition.
When I run Eraser i get the error msg, "this program does not have permission to erase the free space on this drive."
I "run as administrator."
Security settings "appear" to give system and administrator permission to access the drive
Any suggestions?

Running ver., on win7-64-bit, sp1
Hi, wondering if anyone had any ideas Re: my original post? Still having this same problem with Eraser (and C Cleaner as well), wasn't able to find a solution anywhere. Cheers
The actual issue is the size of the files eraser is creating to fill up the diskspace. We will look at how this might be done in the next release.