Eraser shell extension broken


New Member
When I try to erase using shell extension in Explorer nothing happens. Erasing with normal way works OK. I have tried different versions of Eraser and installed and uninstalled + cleaned registry without result. Any ideas to fix this bug? I use Windows XP pro with sp3.
bauxua said:
Erasing with normal way works OK.

When you say the normal way to you mean via the Eraser On-Demand/Scheduler options? Did it ever work for you?

bauxua said:
I have tried different versions of Eraser

Can you clarify which versions you've tried.

bauxua said:
Any ideas to fix this bug? I use Windows XP pro with sp3.

Hopefully with a bit more info we'll get to the bottom of it :) I've not gone to SP3 yet so can't confirm if that's the culprit, although I'd have assumed we'd have heard from others if it was the case.
Yes, "normal" way is to use on-demand window but I rather use shell extension because it is more convenient and faster to use.

This version is Eraser 5.8 (March 31st 2006) and I tried older and newer versions but result was same.
It certainly is the most convenient option. Not much use to you at the moment but I'll build a test VM with SP3 when I get the chance and see if I can replicate the problem you are having.
I've not touched the shell extension code and last I checked it was working. Did the Eraser installer install all necessary run times? Have you reinstalled Eraser?

I have installed and re-installed many times, cleaned register too, but without result. Where I can check in these run times are all installed?
OK, then ignore my runtimes comment.

Are you running your computer in a corporate environment? Do you see the Eraser context menu entry? If you do, do you see anything after clicking on the menu entry? And please only report problems of the latest version. I know you said you tried later versions, but as a general rule, use the latest versions as they will contain fixes.

By the way, have you tried the betas?