Eraser takes long time to load


New Member
Hi. I was using a previous version and am now using Either one, it takes over 30 seconds after double-clicking the Erase icon before the initial screen is displayed. Just wondering if this is normal or do I maybe not have something set up quite right. Thanks.
I can think of two things that may cause this:

1. How long is your task list?
2. Did you have a firewall set to block all outgoing internet connections? Eraser needs an internet connection to verify certificates for plugins which are loaded.
Thanks, Joel, for getting back to me.

I have 3 manual tasks - one for each drive I have - 2 internal disks and one USB which is not connected unless I am using it for a backup or to wipe. I guess I have not tried running the program with it connected. Doesn't seem that should make any difference.

I have no separate firewall running - just Windows' internal. I'm running Winows 7 Home Premium x64 secured only by MSE. I've never had a firewall issue with anything else.

I have an i3 with 4G of memory. Everything else jut pops right up when run. I was expecting you to explain to me why this delay in startup is a normal occurrence but now I'm wondering what's going on. Is there anything else I can supply you that might help understand the situation? Thanks.
That is indeed strange.

How about this. Can you try unplugging your network cable (or disconnecting from your internet connection) and try starting Eraser? See if that helps.
Hey, Joel. I don't know - I tried every combination of network cable connected/disconnected and USB drive connected/disconnected - rebooting between each combination - and in every case it still takes right over 30 seconds for Eraser to come up with it's screen. I thought perhaps a service that is auto by default that I may have set to manual that is taking time to start but, then, I would think, after running Eraser once and then running it again without a restart, the service should already be running and Eraser would come right up - but it takes the 30 some seconds even in that scenario. I have Drivegleam and a network monitor running and have been watching processes in Task Manager as well. I always see the initial disk access when I run the program and Task Manager always shows only Eraser.exe using about 25% CPU time during the 30 seconds. Sometimes I see ongoing disk activity during that time and sometimes not. Sometimes I see a quick blurp of network activity during that time and sometimes not. I rarely see any program get above 15% CPU time starting up. Since no one else has chimed in, "Yeah, me too", if you don't want to mess with it, I don't blame you. But, if you do and you want any other info that might help, just let me know. I don't know if running on 64 bit has any bearing but just a reminder that this is the case for me.
BTW, every time I try to access the forum using any of the links in your emails (via Firefox 20) I get "The connection was interrupted". I haven't had a problem with any other https sights I try to access so I'm not sure what the deal is.
Thank you very much.
This site is without https, I don't see why it'd send you to http.

I can only think of two culprits then. Your task list might be empty but the file on disk is not: try deleting the task list file (I think there's an FAQ entry, basically go to %LOCALAPPDATA%\Eraser and delete Task List.ersx). After that, delete your registry entries for Eraser (you'll lose your settings). HKCU\Software\Eraser\Eraser 6. See if that helps.

I'm assuming that you're on a quad-core (or dual-core with SMT) machine?
OK, Joel!

First, your email contained the correct links this time (no https).

Processor is Intel i3 550 - dual-core with hyper-threading (I believe).

Lastly, and bestly :), I deleted the Task List.ersx file - it was 96k. Before deleting the registry keys, I tried Eraser again and it came right up. Re-created my 3 tasks and the Task List.ersx file is now 3k and Eraser continues to display immediately when run. Don't know what caused the .ersx file problem - I know I probably created and deleted a number of tasks playing around after I first installed Eraser - that may be an issue to check out.

Otherwise, unless having deleting that file means I should also delete the registry keys (please let me know if so), I'm leaving things as they are and everything is now happy, happy, happy.

Thanks so much for your help!
If deleting the task list fixed it, then just leave it as that.