Eraser v. 6.1 beta??


New Member
I am an occasional user and infrequently visit this site. Since I hadn't been here in quite a while, I checked for updates and found that there is no update for version for 6.1 beta. It is recommended now to install stable version 6.0.10 for most users. The version I have now is and it is installed on a 64 bit PC laptop with Win7 Home. My main use is to occasionally erase the recycle bin and wipe free space. I had trouble before with the stable 6.0 version and had therefore installed this beta version which still seems to be working, albeit with a few idiosyncracies. Should I uninstall v.6.1 beta and then install version 6.0.10 to get the most stable, reliable version or should I wait for a future release of say 6.2? Also, if installing v. 6.0.10 is now recommended, is there anything special I need to do to be sure 6.1 beta is completely removed before installing 6.0.10? Thanks for your advice on path forward. - Bill
Humm... I guess no one is interested in my questions. I will try uninstalling and reinstalling the newer version and report what happens. I guess if there are problems someone might then step up and help me.
Ughhh... I uninstalled Eraser v. I searched and deleted all files with eraser in the name on my C: drive. I then downloaded and installed stable v. I got no error messages and it seemed to finish installing without a problem. However, when I tried to run it as administrator from the desktop icon I got an Eraser popup message: "Eraser has stopped working Windows is checking for a solution to the problem". Of course it doesn't find any solution and the popup just goes away after a brief period. The Eraser icon does not ever come into the sytem tray so I suspect that perhaps the install did not really finish correctly. I also get the same Eraser popup when I reboot so apparently it is trying to start Eraser automatically when windows boots. This behavior is exactly the same as what happened in the previous attempt to install the stable version in June, 2010. At that time, I finally got v. to work with a special build sent from Joel after much back and forth. This is exactly what I was afraid of in my original message. I would now greatly appreciate any help on next steps to fix this problem. I am running Win7 Home 64 bit on an HP notebook. If you have an idea about what is causing this issue please check previous chain on the forum " upgrading from 5.8.8 to 6.0.7" that started June 6, 2010 for more information to see if it clarifies my issue. Thanks for any help...
Have you tried uninstalling then reinstall 5.8.8 and uninstall it after a reboot. Then install the latest version?
I have not used v. 5.8.8 since 2010. Are you suggesting that I uninstall the non-working v. and then re-install the old v. 5.8.8? Will it work with Win7 Home 64? Where would I find it? Last time I did that in 2010 it didn't work for on my Win7 64 laptop. At that time I ended up getting a special nightly build from Joel which then installed successfully after some fiddling. Now I am looking for a more stable version that does not have some of the idiosyncracies of Should I actually now try to go back to 5.8.8?
Well it still didn't work. I uninstalled v., then found and installed old v.5.8.8. It installed OK, and I was able to erase a file if run as administrator. I then uninstalled 5.8.8 as suggested. I then downloaded v. and installed. Did exactly the same thing as before. Seemed to install OK, but when it ran i got the same crash message: "Eraser has stopped working Windows is checking for a solution to the problem". I guess if I want to use eraser, I will now have to go back to v. 5.8.8 since the v. 6.1.0,2221 I had working is now long gone. Any better suggestions??
I just down loaded 6.10 and I get eraser does not work with 32bit system. What am I to do?

The issue seems to be a DLL registration conflict , can you check your windows event log and see if there are any messages produced when eraser crashes?
Garrett, thanks for your reply, although it seems to be for the other person posting on this chain. Sorry for my slow response. Actually, I had just about given up on getting any response. To resolve my problem, I uninstalled v. Rather than give up completely, I went into my old e-mail archive and found the 2010 e-mail from Joel that had worked before. This e-mail had an attached special build labeled v. Just as in 2010, it seems to work now when installed. Since this is a beta version, I have no idea what bugs there might be and how it differs from the current stable build. However, it has basically worked so far as I can tell. It is rather disconcerting to see the zillions of warnings in the log file re. system files, etc. when I try to erase free space. There is no way I can check to see if any flagged file carries any personal information risk. It does seem to finish correctly after several hours with no high level errors. I had hoped I could get more confidence in using the latest stable version. Anyway, I will continue with this beta until I get some idea from this forum that further development is continuing and there is a new stable version to try.
There's a post at the top of this forum on what to do when you want to go back to 6.0. Basically, it involves deleting the task list.
Joel - Thanks for the reply. I am currently running with the previous version you sent me back in 2010 which, as indicated earlier, I was able to find in my e-mail archive and re-install. Except for all the lower level messages which are too numerous to actually check, it seems to work OK. My use of eraser is occasional so I can live with this for now. I'll keep checking for new stable versions and will try again when one looks like it may have a reasonable track record with other users. I understand that the support and development for Eraser is by volunteers and I appreciate their efforts, but it sure would be nice to have more intensive development efforts to make Eraser more user friendly but still powerful and reliable. - Bill
OK, you got my interest and I decided to try Eraser again following the hints (nothing to lose except perhaps some time). I uninstalled my older version, looked for everything in start/search that said Eraser and deleted it except for the install *.exe files, and ran Regedit to delete all keys that said Eraser somewhere in them. I then installed the downloaded Eraser Wow, it now works!!! Not sure if it was the registry keys or the task list file that I missed before. Anyway, it seems to work OK now. Still has lots of info messages re. files with sector tips that could not be overwritten, but it is now running at least as well as the old version that I had. Thanks again for the help. :) - Bill