Eraser Won't Complete Task: Wipe Unused Disk Space


New Member
I've been using Eraser for a long time now. It's a great privacy software, and I'm thankful for the creator making available for free.

I had to reinstall windows about two weeks ago. Everything worked out smooth during. Just recently I also reinstalled Eraser. Before I had reinstalled windows I had already had the latest version of Eraser up and running just fine. Now though. It seems any time I try to wipe my unused disk space it never completes. There will always be about two bars remaining in the the status bar. Since I used Eraser Before I'm aware how long a Wipe usually takes. Before my Reinstall it took eraser about 14 hours to complete the process. Now, I left it running twice for almost 24 hours and it did not complete scratch.

I'm running Windows XP with SP3 installed. I have a 232 GB Hard Drive with 186 GB of freespace left. The Hard Drive format is in NTFS. I also have the latest version of Eraser

I've tried using Eraser for other things like file deletion. That works fine. So I'm not sure what the problem might be. I'm going to download and reinstall Eraser again and see it that works. In the meantime, I'm hoping you guys can tell me what might be wrong. I'll go ahead of time and say thank you guys for your help.

- Drunkard
It's a bit of a toss-up whether you use the obsolescent version (5.8.8 ), which still runs well on XP, or the current stable (6.0.7), which, on some machines, seems to fall foul of the Windows free space check, especially on a system disk. Recent development builds are a good deal better, but are not yet ready for prime time.

I find that the less fragmented the free space on a drive is, the less often the problem seems to occur; system drives (even on a new installation) seem to have unmoveable files all over the place. If you didn't format the drive before you reinstalled (or perhaps even if you did, after all the updates), there might be an issue there. But Windows being what it is, that is a rather difficult problem to fix.

As the previous version worked for you, I'd uninstall Eraser 6 completely, delete the task List fill from wherever in you User Appdata folder it is hiding, and (if you can) run a Registry cleaner such as the one in CCleaner to be sure. Then download 5.8.8 from the Eraser page on Sourceforge, and install that. When the next version (probably 6.0.8 ) is released, you could give that a go.

Thanks David for the reply. I was able to fix the problem by running a repair install of Eraser. The process completed with the usual errors. Thanks again for your help.
No trouble. I suspect that there is an element of randomness in this particular problem.

If you haven't already done so, it might be worth checking that the failed free space wipe has not reduced the amount of free space; if it has, just delete the (randomly named) Eraser wiping folder(s)/files that are left.

There was also a bug in 6.0.6 where some of the randomly generated file names started with the characters used as switches for the command lines that eraser actually uses, which caused it to hang. Joel fixed it in a nightly build and added it in 6.0.7, hope that helps if someone else has a similar problem and a repair doesn't help.