Eraser won't open


New Member
I use this regularly, but suddenly it stop working. I'm getting an error and it won't open. I tried to fix it uninstalling and reinstalled, but did not help, including the task folder and registry.

Eraser has stopped working

windows can check online for a solution to the problem

Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: eraser.exe
Problem Signature 02:
Problem Signature 03: 4cd2be16
Problem Signature 04: Eraser.Manager
Problem Signature 05:
Problem Signature 06: 4cd2bde0
Problem Signature 07: 258
Problem Signature 08: 2b6
Problem Signature 09: System.TypeInitialization

My laptop OS is Windows 7 Home Premium
Please see the FAQ post 'Common Eraser Questions', and delete the Task List. This is the commonest cause of your problem.

I've seen this in other instances where the Crypto API cannot be loaded by Eraser (the API is needed for random number generation.) As mentioned earlier, I do not currently know any fixes to this save for reinstalling the OS (as the Crypto API is a part of the Windows OS)
That's useful, in one way ...

The OP didn't respond as to whether deleting the Task List helped, so it's an open question in this instance.

I deleted the task list and the application, it didn't worked so just ditched the program for now until some fix comes up, i hope it soon.
Please see this thread. It's more of a system problem that is the cause. I've also debugged a dump file with such a crash before -- all seems fine, just that the crypto routines cannot initialise.

I could add a piece of code to handle this specific problem, but it would really be pointless -- there will not be a source of entropy (random data used for overwriting). Having no entropy source means that almost every single erasure pass will fail; so in that sense I can't "fix" the problem.
And if I may add... as it is the same problem, please reply to that post. I'll lock this thread.