Eraser won't run after installation


I downloaded and installed Eraser 6 (stable) on my 64-bit Win7 Home Premium laptop. Once the set up finished, it tried to open and I got a windows message saying "Eraser has stopped working..." I tried double clicking on the desktop icon and got the same message. I uninstalled the program and downloaded and reinstalled, this time asking it not to open when it finished. I then went to the setup file and ran it using the "Run as Administrator". I got the same error message.

Can anyone tell me if there is something else I need to do to download and run Eraser 6? Thanks for any help offered and Happy Holidays!

I had 2 updates from Windows Update (some sort of RunTime libraries) just after installing Eraser 6 under XP. Might be worth running Windows Update to see what comes up.
Did you run older versions of Eraser 6 before? Check if %APPDATA%\Eraser 6\Task List.ersx exists. If it does, delete it and try restarting Eraser. Do note that you'll lose all tasks created earlier.