ERASERD erasing files from the wrong directory


New Member
Hi there,

I recently installed Eraser (great program btw). I have a batch file that runs on startup to delete some temporary files, catche, cookies, etc with the DOS deltree or DEL commands. I want to replace this with ERASERD to ensure they are properly erased.

I thought I would do a test first, just to make sure I had the syntax right. I entered the command from C:\WINDOWS (where the Windows DOS shell initially puts you):


All was going well; I could see it going through the C:\WINDOWS\TEMP and erasing everything. Then I noticed some files being erased from the C:\WINDOWS directory! I killed the process, then had to do a dirty reinstall of Windows (all ok).

I tried this again, but decided to run ERASERD from the Eraser program directory. The same thing happened, except it tried to erase the Eraser program!

Is this meant to happen by design? ie. erase everything in the directory ERASERD is executed from as well as whatever file/folder is specified in the syntax?

In the mean time, I have discovered that these directories can be erased on Windows startup with a scheduled task, however I would still like to know how to use ERASERD to destroy the swap file when the computer is turned on (before Windows starts). However, for some reason this scheduled task doesn't always erase the files it should; I can still browse them in Explorer afterwards.

Thanks heaps,
As far as the swap file issue goes, here I just have a checkmark in "Edit/Preferences/General" where it says "Enable clearing of paging (swap) file at shutdown".

I really don't understand why you'd want to make a separate "scheduled task" out of swap file erasure?

As far as the batch-file command goes, I haven't a clue, sorry. Perhaps someone else will chime in on that. Pete