Erasing contents of recycle bin


New Member
At times I find this the only way to erase a file, especially files with custom icons attached to them. These files don't seem to erase properly, Erased with error and leaving the file behind but now with a new name such as "6T3q". But at this time whenever I erase anything from the recycle bin, it will empty the the Recycle bin but it returns the message "erased with errors" and a line remains in the eraser program for me to delete. This does dot occur on any other computer I use. How can I resolve this matter.
David Wilson
It's probably sensible to establish the cause of the error. Using the link in my signature go to the FAQ, and, in the topic Getting to know Eraser 6, see the section on the Task log. Using the guidance there, open the log for your task, and see what the errors were. If, as is most likely, there is a mention of permissions in the message, re-run Eraser as Administrator and try again. Guidance on how to run Eraser as Administrator, which you will need to follow exactly, is in the same FAQ topic.

I was and still am getting a permissions error. I followed your steps exactly and read the error log which indicated a permissions error. So I exited eraser and restarted it with administrator rights. This however did NOT resolve the problem. I have also tried a total reinstall of the program which had no effect on it (problem remained). Do you have any other suggestions.
David Wilson :(
I have known circumstances in which the Recycle Bin folder seems to acquire files which resist all efforts to remove them. In one case, the only way I could resolve the problem was to boot the system from a CD-based Linux distribution, and delete the whole Recycled folder. That's only a little bit better than formatting the drive and starting again. Let's hope we don't have to go there ...

After the erase, does anything show up when you open the Recycled folder; in other words, does Windows think that the Recycle Bin is empty? If it does, can you put some sort of test file in it, and empty it again? If that works, what happens when you put another test file in it, and try to erase the contents of the bin?

If your files are showing up in the bin, can you restore them? If you can, can you erase them directly? If not, what condition are they in; in particular do they have a length, or is the length 0? If the length is 0, the data at least will have been overwritten, and you could just try deleting them, so that the MFT entry is overwritten next time you run a free space erase.

Another option I sometimes use with recalcitrant files is to use the (free) recovery utility Recuva, which has an option to overwrite files it finds. This saves doing a complete free space erase just to remove traces of a couple of files.


P.S. At the risk of sounding fussy, when you exited Eraser before re-running as Administrator, you did close the running process from the System Tray, didn't you?
1. Yes I did fully exit eraser from the system tray before starting in admin mode.
2. When I run eraser on Recycle bin, the recycle bin is emptied in the process and eraser still returns the error message.
3. I am running Windows 7 (32 bit) and on account control settings I am using the lowest setting available (never) as I do no not like being bothered by them and I am the only one on my computer. ( I use the same settings on my wife's computer [Windows 7 - 64 bit] and I am not getting this error.)
David Wilson
What, precisely, does the log for the Eraser task say? You can copy and paste lines from the log into a forum post.

The following is copied from eraser's log:
Thursday, August 18, 2011 5:45:37 PM
Thursday, August 18, 2011 5:45:45 PM Error The file G:\$RECYCLE.BIN\S-1-5-21-1764561827-1716311513-2340144693-1000\$RJWRJ3H\0466a15c68c741f3a4b33ca9d7\$shtdwn$.req could not be erased because the file's permissions prevent access to the file.
Thursday, August 18, 2011 5:45:45 PM Error The file G:\$RECYCLE.BIN\S-1-5-21-1764561827-1716311513-2340144693-1000\$RJWRJ3H\0466a15c68c741f3a4b33ca9d7\mrt.exe._p could not be erased because the file's permissions prevent access to the file.
Thursday, August 18, 2011 5:45:45 PM Error The file G:\$RECYCLE.BIN\S-1-5-21-1764561827-1716311513-2340144693-1000\$RJWRJ3H\0466a15c68c741f3a4b33ca9d7\mrtstub.exe could not be erased because the file's permissions prevent access to the file.
Thursday, August 18, 2011 5:45:45 PM Error The file G:\$RECYCLE.BIN\S-1-5-21-1764561827-1716311513-2340144693-1000\$RJWRJ3H\4d3358473f64f355427a8bff5ba9\MpMiniSigStub.exe could not be erased because the file's permissions prevent access to the file.
Thursday, August 18, 2011 5:45:45 PM Error The file G:\$RECYCLE.BIN\S-1-5-21-1764561827-1716311513-2340144693-1000\$RJWRJ3H\bd716135eb222dbf05e8f046b8b2\MPSigStub.exe could not be erased because the file's permissions prevent access to the file.
It is from my last two time using eraser on the recycle bin, the 1st a regular file and the second a test file. I hope this helps you resolve this issue.

David Wilson
Just to eliminate possibilities, Is drive G: an external, internal or network drive?

Assuming that it is, say, a shared USB drive, I think you may have come across the misbehaviour of the RECYCLED folder that has plagued me in the past. I must do some work to find out whether/how one can delete the RECYCLED folder. In the meantime, it would be a sensible precaution for you to run a disk check on Drive G: and defragment the drive. That has been known to clear the problem in itself, but is probably a long shot.

Defragged my external drive (G-Drive) but got same results afterwards. As you said, it was a long shot but the drive needed it any way, I scheduled it now to defrag once a week since Norton only will Optimize the C Drive and ignores external drives. Now, that is something I didn't previously mention. I am running Norton 360 as a security program. But it doesn't cause any problems on any other computer with Eraser but ??????

David Wilson
If time is not that much of a concern to you, you can permanently delete the RECYCLED and $RECYCLE.BIN folders from drives. Following that, run a free space erase on the drive to eliminate all file traces.

I practice this once every few months when the recycle bin accumulates files which can't be deleted.
Two points to add to Joel's post:
  • you may need to run Explorer as Administrator to get rid of some files; that can be done either from the Administrator account or by running Explorer from an elevated Command Prompt;
  • you may also need to go to Folder Options in Control Panel, and, under the View tab, temporarily disable the option to hide protected operating System files in order to see the folders in Explorer.