Error error and error


New Member
I´ve tried eraser in 2 computers and always get error after it starts to delete some files...

Problem signature:
Problem Event Name: APPCRASH
Application Name: Eraser.exe
Application Version:
Application Timestamp: 4d22a9d6
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7600.16385
Fault Module Timestamp: 4a5bdaae
Exception Code: e0434f4d
Exception Offset: 00009617
OS Version: 6.1.7600.
Locale ID: 1046
Additional Information 1: 1d32
Additional Information 2: 1d32409995138d855a2b9bb446ccc159
Additional Information 3: 591c
Additional Information 4: 591c8f267d7c87f1375dd28c7ce78903

What´s wrong with this software?

I´m using that option that re-writes files that you have in your disk over the deleted data.
and yes I´ve stoped eraser.exe and then run it as administrator. Tried both direct start and remove after restart, both app crash.
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: eraser.exe
Problem Signature 02:
Problem Signature 03: 4d22a9d6
Problem Signature 04: mscorlib
Problem Signature 05:
Problem Signature 06: 4bebe8e2
Problem Signature 07: 349e
Problem Signature 08: e1
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7600.
Locale ID: 1046
You have been really unlucky to get this on two machines. I too have seen this error with this function, and it has been reported to Joel (whose unavoidable work commitments are, unfortunately, keeping him away from Eraser at the moment).

What I think we have established is that it is not some simple error in the code that is creating this exception; it could actually be an issue in your .NET installation. If you search the forum on 'Dependency Walker', you will find explanations of how to use a small application that you can download to test whether, in your installation, all the dlls required by the program are actually present. I have had on occasions to copy files from one folder to another to get Eraser to work. This, when it happens, is not a problem which any change to Eraser as such can fix; it is, as I said, an issue with .NET, which to all intents and purposes is a component of Windows.

The latter error can be caused by an invalid Task List, try deleting that. If that doesn't resolve it, delete the Registry keys for Eraser as well (HKCU\Software\Eraser\Eraser 6)