Error: Failed to clean directory entries from drive C


New Member
I'm using Windows 98SE. I erased a file with Eraser 5.7 and it gave me the following message:

"Error: Failed to clean directory entries from drive C:\, there was something not quite right with the file system. You may want to run ScanDisk."

I ran ScanDisk and it still gave me the same message after erasing a file.
I uninstalled and re-installed Eraser and I get the same message.

Any ideas on why it's doing this?
This error message means that Eraser found something it wasn't expecting from the file system while trying to overwrite the file name, and decided not to proceed any further in order to prevent file system corruption. Unless you received further errors, the file itself was successfully overwritten.

I have heard of similar problems a couple of times before, always from people running Windows 98, and usually on a computer bought from a major manufacturer. Unfortunately, I was never able to reproduce the problem myself, and without access to a system where this occurs, there is very little that can be done to solve it.

However, some people have reported that the problem went away after defragmenting the drive. If that doesn't help, you can still get rid of the error message by disabling file name erasing from the "Erasing Preferences" dialog. If you are worried about file names remaining on the drive, defragmenting it every now and then will clear them.
I tried defragmenting the drive and I still get the error message. As long as the files are successfully overwritten then I'm happy. Thanks.
Here's an update. I tried defragmenting the drive again and now I don't get the error message when I erase a file. Eraser works perfectly now! Thanks again.