"Error: Failed to clean directory entry.... - Why?


New Member
I just ran Eraser to wipe my unused space and to clear directory entries (running a Dell Inspiron 5000 notebook with Windows 2000 Pro). When finished, it gave me a bunch of 'error' listings in the Erase Report similar to this:

"Error: Failed to clean directory entry C:\, could not prevent other programs from touching it."


"Error: Failed to clean directory entry C:\PHOTOS~1\WOWPRO~1\, could not prevent other programs from touching it."

There were a LOT of these entries in the report, for various directories on my C: drive.

What will cause the above and how can it be 'fixed'?

This is probably because you have programs running whose executable files are in those directories. This prevents Eraser from locking the directory. You can reduce the number of these errors by closing all running programs before erasing unused disk space. Not all of them can be fixed though.
I've tried Eraser on several different computers now and I've noticed that I never have this problem with these 'errors' (failure to clean directory) on the machines that are running Windows 95 or Windows 98. This problem only shows up on computers running Windows 2000 Pro. Also, directories are showing up in the 'error lists' that do not have executables in them at all as well as directories that have executables but those executables definitely are NOT running. I've also tried other 'cleaning' programs that don't seem to have any trouble at all 'accessing' these directories to 'clean' them - only Eraser seems to be having this problem. Any suggestioins?
It probably has something to do with Win2000 being a more secure OS then 95/98. I think it is more aggressive in 'locking' ( denying access to ) files and directories.
The main problem directories ( at least for me ) are :
1) Any directory that has file(s) that are 'in use'
2) The directory that Windows is installed to.
3) Any directory that has 'win' or 'windows' in the path. ex. c:\windows\desktop
Windows 2000 Pro being a more 'secure' OS, as compared to Win95 or Win98, makes sense. But, what I don't understand is that Eraser is the ONLY program that I've tried (and I've tried several now) that has this 'problem' with not being able to access certain directory entries. And, as I already mentioned, some of these directories do NOT have any executable files in them (and NO files 'in use') and in some of these directories that do have executables in them, those executables are NOT running (again, NO files 'in use'). It almost appears that Eraser is a bit too 'careful' in accessing directories and files, such that it won't access such directories and files that would be perfectly 'safe' to access.
I believe it's better to be careful than corrupt your files, no? Eraser uses a different method of clearing filenames than most other programs, one that actually works. If a directory entry cannot be locked for exclusive access for whatever reason, it won't be touched. If someone were to modify it at the same time, the results would not be pretty.

Oh, and if you really care about your privacy enough to be concerned about remaining filenames, I suggest you create an encrypted partition (and I don't mean NTFS here). Overwriting data after it has hit the drive is no substitution for real security.
Yes, I know there are programs that 'claim' to do a great job at deleting the files AND clearing filenames, but that don't really work. And I see exactly what you mean about being 'careful' as to deleting data. It's really pretty rare that a filename would need to be 'cleared' - really, filenames on any of my machines aren't going to 'give away' any 'critical' or 'private' information at all. I guess it's just been a bit 'intriguing' as to how these different programs work (or don't work) - must be the 'programmer' in me coming out. :)