Error Message "The parameter is incorrect"


New Member
Hi, I have just installed Eraser32 Ver. 5.56.1 and when I run it I get the error message "The parameter is incorrect", I click OK in the box and Eraser seems to start.
I get the same error "The parameter is incorrect" at start-up when eraser loads into the task-bar.
it is very difficult to generate new tasks as the file selection (browse) box keeps returning to the root directory level of the drive before I have time to select anything.

Are these problems related and is there a fix available?

System = Dell laptop running Vista Home Premium
Thanks for you help.

I tried both of the versions that you suggested, neither solved the recurrent Error Message problem or the difficulty in actually selecting something to erase. The beta did however pick up a list of tasks from a previous attempt to install Eraser. Does this mean that the uninstall process is leaving some bits and pieces behind (I run the uninstall before installing)? I did run the tasks and the actual erasing seems to work OK. It's just that the error messages on start-up, when I run the program and when I close the results box are very irritating.

Is this problem unique to me? I have AVG anti-virus running if that's any help.
I think it'd help if you mentioned when was the last time you reinstalled your computer OS and stuff. Errors like these tend to creep up after a while. Do any other pograms display the problem?

I have never reinstalled my OS :roll: . The laptop came from Dell with Vista home premium installed (in January) and the OS is up to date. The error does not appear with any other program, windows doesn't crash unexpectedly and Eraser works perfectly from the Explorer menu. I only get the error message when I run the main program and attempt to perform a list of tasks. Removing/disabling the scheduler has stopped the error message appering at start-up.

Hope this helps
admin said:
Can you try this version

Reinstall any previous version first.


I have just done this, the new version is better in that it is easier to generate tasks by browsing for files to erase, not perfect as the browser window still jumps back a few directory levels at random, but just about doable (could this be to do with using a touchpad rather than a mouse?). I still have the error message when eraser starts or the scheduler is enabled at startup. I turned off UAC but this made no difference.
Well... I don't know how to debug stuff like that. But if it's been a long while since you last reinstalled your OS... you could try doing that. Added benefits include a blazing fast computer. I have issues sometimees which just spontaneously resolve itself after an OS reinstall

As to the jumping file selector, I'm aware of it, but I can't fix it. The contorl itself wasn't meant for Vista so it does act weird. v6 will not have the issue.

I have now fixed this problem by deleting file "default.ers" from the eraser directory.

I had noticed another bizarre bit of behaviour, I seemed to have two task lists that appeared alternately. one with no tasks in it and one with my saved tasks. If the blank one loaded I would shut down eraser and relaunch it to get the other one.
With time on my hands I had a look at the eraser directory and the only thing that looked task related was "default.ers" so I deleted it! This seems to have cured all the problems including the error message :D
It's much easier to select files to erase now :D

Any ideas why?
I think that the problem with the jumping file selector was fixed after a related UI bug was fixed yesterday... I don't know. It sure looks like it though. I'll release a beta later today and you all can seefor yourselves :)