Error Message = Unable to resolve locked files. Cant open fi

Keith Bradford

New Member
When I boot up the PC before all programs load a window appears with "Eraser Launcher" in the title bar and "Unable to resolve locked files. Cant open file list" in the text box. When I press the cancel button in the box the PC continues to load and works fine. Same message appears every time I start the PC. I am using the latest version of Eraser and XP with service pack 3. I cannot expalin what happened before the message appears as all the family uses the PC and no one will own up.

How do I get rid of the message, please?

Open up eraser, go to the Scheduler window and see if there are any tasks set to run on reboot. If so remove the task, reboot and see if the problem persists
Sorry for not getting back to you sooner.

There isn’t anything in the scheduler.

I have managed to get rid of the Launcher window when I boot up but it has been replaced by a windows explorer window.

I have found an entry in the start-up menu called eraserrestarterase (1). This was linked to C:\\windows\system32\long number.(null). I have deleted the startup entry but it just reappears as soon as it is deleted. I have tried to find the file it leads to but it does not exist. I can modify the entry so that a different explorer window opens but I cannot get rid of it. I cannot find a file in active tasks that is generating this entry.

I notice that someone else has got this problem which was resolved by uninstalling eraser and deleting all entries in the register relating to eraser. I have uninstalled eraser and deleted all entries relating to eraser, eraser1 and eraserrestarterase. However the registry entry eraserrestarterase (1) still appears in the registry in "MyComputer\HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CurrentVersion\RunOnce". If I delete this entry in the registry it just reappears. I can modify the path to lead to any file which duly runs at start up but if I delete the entry completely it just reappears and the file I have made it lead to opens when I start the PC.

It is driving me nuts

Any suggestions, please?

Keith B

I found out how the error occurred, replicated it and in doing so solved the issue. The PC works perfectly with no error messages and so does Eraser.

An attempt was made to erase a file that was in use. Eraser gave the option to delete on reboot which was accepted. However before rebooting, the program using the file was closed and the file erased with eraser before turning off the computer. This resulted in the error messages and explorer opening.

By replicating the process with a different file after upgrading to the latest beta version of eraser, on rebooting an eraser window opened telling me the file could not be found. I closed that window and the PC has worked fine since. The entry has not reappeared in startup programs.

Thanks to all those who gave this some thought or even replied to me.

Cheers KB
Thank you Keith for posting your discovery !

Just because people haven’t posted here doesn’t mean they are not thinking about your problem. I am grateful you took the time to post the solution so others may find the answer on the forum.

Thank you for helping and I hope this hasn’t put you off Eraser ! Eraser V6 should be released around Christmas time which I believe will be a leap forward in reliability and performance.

I hope you take the time to download it and give it a try.