Error The RPC server is unavailable


New Member
"Error The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)"

i've recently installed version 6 on my laptop. v5.x worked a charm (save for some dead directory entries that won't disappear) but for some reason wiping free space is impossible for me. now i've tried the usual to solve a RPC issue - checking that the rpc services are running, netbios, tcpip, firewalls are open for the app etc - but to no prevail. any ideas on why this might be happening?

i'm using XP with the .NET framework installed.
That sounds like you were doing a free space erasure; I just fixed a bug regarding this a few hours ago, apparently the documentation for one API call I did was changed without me knowing. You can try any nightly builds greater than or equal to r1473 to have this fixed.
dude, seriously, you're awesome. i'm a huge fan of your work :) i'll be donating you a coffee.

EDIT: after downloading and installing the latest nightly build, the application crashes upon execution. it says it can't find a missing plugin. sadly, i couldn't catch the filename :?
the windows error report says the following:

EventType : clr20r3     P1 : eraser.exe     P2 :     P3 : 4b26dc33
P4 : mscorlib     P5 :     P6 : 4a7cd8f7     P7 : 219d     P8 : 0     
P9 :

for some reason, after i uninstalled, not even a clean install of the stable version would start the program up. i am well and truly out of options now. i guess it's back to 5.8 for me.
OH, I installed the latest nightly and forced the system to rebuild it; apparently the 64-bit version of the installer included a plugin which was not signed. To get the stable version to start you'll have to delete %LOCALAPPDATA%\Eraser 6\Task List.ersx. Strange thing is, I've been using versions which keep changing and have never experienced such a crash before...

EDIT: The r1484 build should work fine.