External Drive Failure After Cleaning Unused Space (Vista)


New Member
I have a 300GB external hard drive w/ 128GB of free space before cleaning the unused space (v. 5.84.) Windows will no longer recognize the drive and insists on formatting.

I've tried all forum suggestions (that I've found) w/ no luck.

Eraser shows the unused space currently at 1KB. Which leads me to believe the all the free space is consumed by tenporary files. Does anyone know of a solution w/o having to format the drive? Any/all suggestions would be appreciated.

These are the errors I get when trying to run Eraser again to clean the unused space w/o Cluster Tip Area checked.

Error 1: Failed to determine cluster size drive X:\. Cluster tip area will not be erased.

Error 2: Failed to create temporary directory drive X:\, maybe one already exists try again.

Error 3: Failed X:\
Hi HighAlpha

Welcome to the forum.

I am sorry you are having trouble with Eraser.

It sounds to me (just a guess) as if your MFT has been damaged. Try this link.

I doubt that this was caused by Eraser, could your external drive have been knocked or the power disconnected while Eraser was running ?

You might be better off recovering your data with some recovery software before trying to repair or restore your MFT.

Let us know how you get on.

No power outage or knock. DIsk ran perfect before starting Eraser. I was running Eraser on both C: and the external. C finished flawlessly and the external never recovered.

I can't access the external from DOS and I've tried running CHKDSK w/ no luck.

The "used" portion of the disk shows as RAW. I had 14MB of unallocated space, whick I assume was the temp filess filling the disk. So I formatted the 14MB but I'm still unable to access my data whick resides on the RAW portion of the file system.

Thx for the reply. I'll keep trying to recover so if you have any other suggestions I'd be happy to hear them.

I think you need to use some recovery software rather than just trying to run CHKDSK.

You may want to try to search for freeware on Google or Yahoo. I would start by using the term “data recovery freeware” or such like.

I cannot explain what has happened to your drive, but I very much doubt Eraser caused the problem. If you manage to recover your data and re-format your external drive would you perform another free space wipe test for us please ? Just to make sure Eraser is working ok.

I can say w/ some certainty Eraser caused this particular problem. I will do what I can to recover. Since I use this drive primarily for backup and program files, I've lost some important data. Once I get it "fixed" I'll try erasing the free space again and let you know the outcome.

This is the 2nd time I've erased the free space w/ Eraser & Vista OS, so I know it worked once before.

Like I said, since I've probably lost over 150GB worth of data, I'll try it once more to give you feedback and make Eraser better software. Your efforts are commendable for making this software free but I doubt I will use it again and risk other major data loss.

I sincerely appreciate your assistance and the time and effort you've provided to me and the computer community. I'll let you know what happens once I figure out what I'm going to do. If you come across any useful info I'd be happy to give it a try. I'm going to mull over my options for a couple days just in case there's hope.

Thank you again and best of luck w/ Heidi Computers.
HighAlpha :)

I can say w/ some certainty Eraser caused this particular problem.

This is the 2nd time I've erased the free space w/ Eraser & Vista OS, so I know it worked once before.

I wonder why you would think Eraser works ok one day and then not another ? I am sure the drive failed whilst Eraser was running but can we say Eraser damaged / caused it ?

I have an idea, does your drive make any clicking noises ? When Eraser is run on a drive it makes the drive work pretty hard. This is not a bug or fault of Eraser but by the very nature of overwriting an enormous amount of free space any drive that is faulty or about to fail may be pushed over the edge when using Eraser.

Now I don’t want you to be put off using Eraser but this is a fact that everyone needs to know. Any faulty drive can fail completely if stressed. This doesn’t have to be Eraser, any mass writing of data to a failing drive will cause a problem. Copying a DVD for example could be enough to make a bad drive fail. Actually I know that the creators of a certain disk defragmenting utility regularly get accused that their software has damaged / broken someone’s hard drive when in actuality the drive was failing anyway. I just so happens to be stressed when defragging.

So I hope you understand my point that it may not be Erasers fault.

It would be a good idea if you could leave things for a little while, let us have a think about how best to carry on from here and save your data. Please don’t do anything quickly as Joel (the eraser bug fixer) will no doubt read this thread soon and he may have more constructive comments than I can provide.

I would really appreciate it if you could test the drive again if it is able to be fixed at a later date. Although I personally doubt that a bug in Eraser caused this problem I could very well be wrong and if so we need to know about it as you could be the first of many people to experience this ! I hope not ! :(

Stick with it and I am sure we can sort something out amongst us all. :wink:

No. no clicking noises. FYI, it's a Maxtor One Touch II, 300GB. It starts normally but I just can't access the data. CHKDSK reports 0KB of used space & 0KB of free space. Using Administrative Options, Disk Management in Vista shows 279GB of data RAW file system and 14GB of unallocated space that I formatted using NTFS. Both partitions show Healthy, Active partitions. Maxtor diagnostics show everything is working normally.

I completely agree w/ you for the most part and I don't need it fixed immediately. I'm willing to try most anything to save the data. Formatting will be my last choice. I can't positively say it's Eraser's fault but the disk has been flawless since I've owned it for 2 years. I'd really like to find a solution to repair the file system so I'm all ears when it comes to suggestions.

Like I said, I sincerely appreciate you taking the time and offering assistance. Hopefully, we can find solution. Thank you again.
People often complain about drives getting corrupted. I'm sure that's true. Now, remember that Eraser and a whole host of other apps which do disk services exist and they pretty much stress the hard disk.

The hard disk is mechanical by nature and thus is one of the most fragile components of your computer. What people don't realise is that hard disks therefore have a very volatile lifespan depending on how they are used. External disks tend to screw up faster due to the way it is handled (unplugged, shock, dropped etc).

You mentioned it is an EXTERNAL hard drive. This would increase the likelihood that your disk has been mistreated (not saying it has). But the other counteracting factor is that you have a 300gig disk. That probably means your disk is pretty recent.

So first question. How old is your disk?

Next. Eraser does not stress your disk by unorthodox ways (I'm serious). We go around writing files to disk just like any other program - even to conduct the free space wipe. If corruption occrus after an Eraser pass, a few options can come to mind:

-old disk
-disk screwed up the magnetic data
-file system corruption which was present before but not rectified

All the above problems (especially the last) leads to a cascade of disk failures.

So the second question - if your disk is new, when was the last time you ran chkdsk?

I hope the answer above helps you in your question for answers.
Overwriter said:
Please don’t do anything quickly as Joel (the eraser bug fixer) will no doubt read this thread soon and he may have more constructive comments than I can provide.

See, I told you he would turn up soon !! :D
Hi Joel,

The disk is approx 2 years old and I'm meticulous about everything, especially my computer. I regularly (weekly) run CHKDSK, Defragmenter, and an avid user of CC Cleaner. The disk has never been dropped or mistreated. As a matter of fact it hasn't been moved in over a year.

I just started to use Eraser about a month ago. I've cleaned the unused space before and I'm pretty sure it was v. 5.84.

This time, Eraser stated that the external had 134GB of unused data to clean. I was prepared to let it run over night since I had the C: drive scheduled as well. But when it started to "clean" the external, it finished rather quickly, say 10 minutes and then started on the C: drive. After all was said and done, I can no longer access the external.

Thx for the reply.
By any chance - did you use the first/last 2kb option on your external drive? Were you using earlier versions of 5.8 before the current 5.84? What does Help | About say? did you just reinstall a new version of Eraser?
I used the the default settings when I installed 5.84. It was set to: Free Disk Space (and Master File Table Records), Cluster Tip Areas, and Directory Entries. The only thing I changed was the number of passes to 3.

Like I said, it worked the first time I ran it and it worked on the internal drive. But somehow, the NTFS file system was changed to RAW while running Eraser.

"Only first and last 2KB" is not an option in the Erasing Preferences tab for Unused Disk Space.
Hm. I can only explain that with "catatrophic drive failure" or "acts of God"... the only way you can nuke your drive THAT bad is by a virus (going round killing drives' firmware and sending rogue opcodes) or if the drive gave up and decided to die.

AFAIK the "file system" and other stuff like that (partitions etc) are pretty much out of bounds to standard Windows programs so I don't really think Eraser could have corrupted your drive.

My Maxtors are still working after nearly 7 years so I guess age isn't that big a issue here...

I'm at a loss to at how to retrieve your data...

The one thing I can however do is to advise... that we replace our drives often! (I try to do once in 2-3 years, then again I stress my disk a lot doing programming)

I've never had (on my personal computer) any type of virus or spyware for that matter. The drive is fine. I can access the NTFS portion of it, I just can't access the RAW file system where all my data resides. If there was a way to convert the RAW FS to NTFS w/o formatting, I'd be where I started before running Eraser.

Oh well, I guess life moves on. Thank you Overwriter and Joel for taking the time to offer solutions.

Take care and best of luck w/ all your endeavors.