Failed to create temporary directory to drive X


New Member
Dear all.
Would you kindly help me??
When I tried to erase UNUSED DISK SPACE on a USB-connected MO disk (230MB), an error occurred with the following message:

"Failed to create temporary directory to drive X:\, maybe one exists already. Try again"
Failed: X: filename
Failed: X: filename......

As a result, some parts of the MO disk were treated properly, but others were failed: i.e., file slack was remained unerased.

When the disk was treated by other machines (even repeated), the result was the same.

What does the message mean??
What is the cause of the error??
Do you know any solution??

Kind regards,


PS: OS = WinXP (SP3). Ver of ERASER = 5.7.
It just means that an old ~ERAFSWD.TMP folder is in the root of the drive. Delete the folder and it should work.

I'm having a similar issue with one of my drives. The erase free space worked great on a 1.5TB drive, but am receiving an error similar to above on a 500GB drive. I do not see any temporary files in the root directory of any of the drives. I have "show hidden files" enabled, and still do not see them. I'm running Windows 7 Ultimate x64. All of my HDDs are formatted NTFS. Thanks!

  Error: Failed to create temporary directory to drive D:\, maybe one exists already. Try again.
  Error: Failed to create a temporary file or directory. Erasing was not completed.
  Error: Encountered an improper argument.
  Error: Failed to erase file names from drive D:\, don't know why exactly.

Contents on the drive root are as follows:
 Volume in drive D has no label.
 Volume Serial Number is 45DF-B2C5

 Directory of D:\

07/30/2009  07:41 PM    <DIR>          backup
10/15/2009  09:50 PM    <DIR>          Downloads
06/23/2007  02:47 PM    <DIR>          mp3
05/16/2009  02:12 AM    <DIR>          Temp
11/15/2009  05:30 PM    <DIR>          VirtualBox
01/25/2009  02:17 PM    <DIR>          WD Backup
               0 File(s)              0 bytes
               8 Dir(s)  281,358,999,552 bytes free

Try dir /a instead. That error message is only released in one area and it's due to the folder either already existing or you do not have permissions to access the drive. Can you also create a folder in the root of the drive?