Freespace Wipe - "Access to the path..." is denied


New Member
I searched the forums and didn't find a reference for this problem, please let me know where I can find the thread if I've overlooked it.

I did a freespace wipe of a recently reformatted drive and received the error
Files in H:\System Volume Information did not have its cluster tips erased because of the following error: Access to the path 'H:\System Volume Information' is denied.

OS: Windows 7 Ultimate 64-bit

Eraser is already being run with Administrative privileges (compatibility option set on the .EXE itself). I think this is a problem I've encountered numerous times since I first started using version 6.0.xx. I've had 6.0.9 running on my computer for about a week now after having (clean) reinstalled Windows 7 only recently. Eraser method was US DoD 5220.22-M (3pass), though I'm fairly sure I've run into this with other erasing methods as well. The partition in question is about 60gb. I have an entire terabyte I intend to freespace wipe and want to be sure Eraser is going to do it's job correctly. :)

Anyone have an idea what this error is about, how concerning it is, or how to work around it?
Thanks! :)
The most likely reason you are having this problem is that you are not closing the running process before starting Eraser. The .exe may be running with admin. privileges, but the running process (which contains the erasing engine and typically starts with Windows) will not. That is why the advice is to stop the running process and then explicitly run Eraser as Administrator when you wish to erase free space. It does not need to be run administratively all the time, as most of what Eraser does does not require that. All of this is documented in the FAQ posts referred to in my signature.

You are correct in thinking that the erasing method is not a material factor here.

Joel plans that, from version 6.2 on, the Eraser engine will be run as a service, and the issue will hopefully then go away. But the change will require a lot of development effort, and, after a couple of very busy years, Joel is only now starting to update the development infrastructure for version 6.2 (moving on from .NET 3.5 to 4,for example). We are going to have to be patient.

The System Volume Information folder cannot be touched by anyone... including administrators. There would be no way to erase the cluster tips of files in that folder.

CCleaner uses a Windows API to handle the system restore points (stored in that folder) but it does not securely erase the restore points (which, as we have discussed before, is very dangerous since it contains information unknown to us, but usually what we want to get rid of)
Hi Joel - I was reading this thread because I ran into the same error with the System Volume Folder not having the cluster tips erased. I was wiping free space on a drive and received this error. All the error means is that the cluster tips in/around that folder weren't erased, right? The rest of the drive completed successfully I assume? I don't think that was addressed anywhere and I just wanted to make sure :)
You are correct in your conclusions. In the nature of things this is quite unavoidable, and therefore will not be flagged up as an error in future versions of Eraser.

The likelihood that sensitive personal data resides in the cluster tips of protected system files is, when you think about it, fairly remote, and it would require a more than usually well-equipped and capable adversary to access that information. Most of us, sadly, have much softer targets on our hard drives.