1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having problems on Windows 7, 64-bit version.

Discussion in 'Eraser Support' started by JoeDoe5, Jun 26, 2012.

  1. JoeDoe5

    JoeDoe5 New Member

    My OS is Windows 7 Home Premium x64. I always right-click on Eraser and then click Run as Administrator, to start Eraser. However whenever erasing anything, it doesn't work, and instead returns an error message in just a couple seconds. Result, my file is still there (even ordinary Windows "delete" is better than this!). The message is "completed with errors" (although it would be more accurate if it said "it never completed, and never even got started, because it encountered an error").

    When I go to the log the program keeps, it says this:
     
  2. Joel

    Joel New Member

    You seem to have got a corrupt install. Try uninstalling and reinstalling and see if that does anything. If it doesn't, check that the packages you are using to install are signed by me (and that the certificate is valid).
     
  3. JoeDoe5

    JoeDoe5 New Member

    Tried reinstalling a number of times. It didn't work. I'm using the latest "stable" build from the downloads page on this site. I did not get it from a 3rd party site. I assume the builds on your site are in fact properly signed. Finally I tried the most recent "nightly" build, and it works for securely emptying the recycle bin, but not erasing just any files from within Windows explorer. It doesn't give an error message as the previous version (the stable version) did, and so it looks like it actually did something, but in fact the file still remains.

    Can you please make a version of Eraser that is DESIGNED to work in 64bit Windows 7? I think that would fix a lot of bugs it seems to have.
     
  4. Joel

    Joel New Member

    I develop and test Eraser on 64-bit Windows 7. It works fine. There has to be something wrong with the particular environment your system is on.
    Do not assume that the files are signed when you get them. Incomplete or erroneous downloads can still cause them to be invalid; or worse, a malicious copy may be what you've got.
     
  5. Lazerus05

    Lazerus05 New Member

    HOWDY!!
    Cannot get it to work either schedualing or doing it manually.
    within seconds get compleated with errors. I have'nt been able to get it to work with windows 7 Ever. been trying for 2 yrs.
    #1: Windows 7 Home Premium 64 - bit
    #3: 8 gigs Ram / Intel Core 2 CPU 6700@2.66GHz @.67Ghz
    #4: 80 Gigs Intel Solid state HD
    #5: Broadband
    #6: Actiontec (2 in 1) Wireless N DSL Modem GT784WN
    (New 03/26/2012)
    #7: From Home
    #9: Isp - is Centurylink
    #15: Avast Free antaivirus
    #16: West Coast Florida

    I cannot get HD(C) or any of the 3 (2 tb.) Storage drives.
    to errase unused disc space.
    I See others have the same problem.
    I will check back when I recieve notification of an ans. Iwill try again in 1 yr. maybe you can have it fixed by then
     
  6. DavidHB

    DavidHB New Member

    When things go wrong with an Eraser installation, sometimes no amount of reinstalling on its own will work, and you have to do all you can to remove the traces of the previous install. Search this forum on the term "brute force" for information on how to do this. So far (including testing some rather flaky development builds) I have never failed to get Eraser working properly after a full uninstall and reinstall, on a variety of Windows 7, Vista and XP machines.
    David
     
  7. Somes

    Somes New Member

    Hello.
    I got exact that problem with my Win7 HP x64.
    How i deal with it:
    from "As administrator" runned command line I enable my local Administrator account, that command:
    >net user /Active:YES Admininstrator
    (without ">")
    Because in Home editions you haven't that nice mmc snapins for user control.
    Next i go through control panel - users and accounts - set password for my local Administrator
    After that you must hold Shift key and right click on ereaser execute file or link, and chose "Run as another user".
    It`s take some time for first run (about 20-30 seconds).
    I hope that was helpfull. Sorry for my english.
     
  8. WSB

    WSB New Member

    I also have this problem and it makes Eraser unusable - However I might have found the answer?
    In my case most of the problems were due to Comodo firewall "protecting" whole swathes of the hard drive as part of it's "security". Now I only wanted the free firewall, but all the extra "security" is included with even the free firewall and it does not seem to turn off completely, even when you tell it to.

    For example, IrfanView could see, save and edit photos in the root directory of c:\ but I couldn't! At least not using Windows explorer as I was locked out of my own c:\ directory.

    The problems became so bad that I have dropped Comodo firewall for the freeware "Private Firewall" which seems as good, but does not come with all the unwanted "security".
     
  9. yelmarb

    yelmarb New Member

    I too am having the same issues. Wasted hours with a full uninstall, re-installing, changing the permission from the program folder, turning off the firewall and running the program in admin mode after quitting etc etc but it doesn't make any difference. I still get a permission error with nothing erased. I'm running Windows 7 64 bit... and every other app runs fine.
     
  10. korence

    korence New Member

    To Windows 7 problems, the more that I know is how to speed up Windows 7 computer. The guide for that was found on Google. More details about this guide you can search Windows Password Key on Google.
     

Share This Page