HD asking for format?


New Member
Hi, i was testing out Eraser today, so for starters i just tried the first and last 2KB option on a file, but it failed, so i just did a single pass psdeudo(sp..) random on the file, worked fine, but afterwards i had to restart after installing another program, when i logged back on, my drive was blank and windows is asking for a format :(

If anyone knows how to get around this id appreciate it, or if i should just use some recovery program im open for suggestions on which one.

The drive was a.... backup backup drive, so nothing terribly important was lost, but there were a few things and id like to get it back if possible.


Can I just ask what version of Eraser you were using, as this used to be a problem on an older version but it has been fixed some time ago.
Yes 5.86.1 is the latest version which will “not” have the first and last 2kb bug. I am guessing / hoping this is just a coincidence.

What file did you delete ? Could it have been a system file by mistake ?

I have XP pro SP3 Eraser 5.86.1 and I have just deleted a file with the first and last 2KB with no problem.

Could your drive be faulty ?

Could anything else you have installed caused this ?

I am sorry to ask so many questions but this is a serious problem you have experienced and I don’t want you to think Eraser caused it. Many people are using Eraser 5.86.1 and I don’t think anyone else has had this problem but there may be something unique about your setup that needs investigating.
Well for starters, the file was just a ~300 MB avi file and i use Windows XP SP2.
I use Comodo Firewall and Anti-Virus.
I dont think my drive is faulty, and this drive is drive F: so no system files, and nothing else should be effecting it.

If there is any other info you need just ask.
I can’t explain that. This really shouldn’t be an Eraser problem.

Just a couple more questions.

Have you tried to "check disk" the drive ?

Do you use Truecrypt ?

What was the other program you installed before rebooting ?

Could you copy another file of any type to any external drives you have and try Eraser again please ?

Ok, it is odd, i tried it on my empty flash drive, the 2kb FL worked fine, i didnt get the fail like i did on my HD.

Maybe your right on, cause i did install truecrypt right before trying to delete that file, BUT! I did not do the restart to complete the install on it, cause i was listening to a song and... yeah.

So maybe a half install of truecrypt + the 2KB erase = nono?

I would try out the 2KB on another HD i have to make certain that this same thing wont happen again, but id rather not risk the same thing happening <.<

If there is some way to get my drive back up and running, i could try it again on the same one.

Oh, and checkdisk wont do anything to an "unformatted" hd, even undelete wont work on it. Do i have to format it before i can recover any files?

Thanks for your help, its appreciated :)
If there is some way to get my drive back up and running, i could try it again on the same one.

Well the quickest way would be to reformat it but then you would loose the old data.

There are some recovery programs that would help recover anything you really needed from a formatted or corrupt drive. The best one I know is a commercial one but we are not allowed to advertise here. I am sure there are free versions of such software.

If there are files on the drive you must recover I wouldn’t format it first in order to try to recover them.

I have just tried the 2kb pass on an external hard drive here and all worked well.

As you use Truecrypt did you encrypt the external drive ? As in the whole drive ? Even a partial encryption will damage the formatting.
Nope, i had just installed it (truecrypt) and that was that, cause like i said, i needed a restart to complete the install (which i didnt do at the time), so i hadnt used it at all.

Would it matter at all if the drive was basic or dynamic? (also to clarify its just an internal IDE drive, i was just testing on my flashdrive to see if i got the same results)

Well, its probably just my system, or something i did, i tweak and mess with a lot of things (and break them in the process) screwing up a HD or windows install is nothing new, thats why this hard drive was a backup backup :lol:

Most i lost were a couple music videos i liked, easy enough to get back.
Most i lost were a couple music videos i liked, easy enough to get back.

If that is the case then I suggest you format the drive and test.

Could you format the drive, copy any file to it (perhaps the exact one you deleted would be best) and then try to overwrite it again please ?

I would be very interested to hear what happens as we need to make certain this is not an Eraser problem.

If it makes you feel any better I tweak and mess with my drive so much I consider myself lucky to get a whole month before having to re-install !! :roll:
Nope, it all worked fine, the 2kb pass didnt fail either.
I did everything the same except i didnt have the truecrypt install waiting for a restart in the background. (i dont think that would effect it)

Just a one time thing maybe, pretty weird hu.
Yeah, could be just one of those things ! Thanks for writing back to let me know.

I hope this hasn’t put you off Eraser !!
Installing truecrypt has a side-effect of installing a low-level driver. It should not affect Eraser's behaviour the least bit, but yeah it may be a plausible hypothesis. I kinda just skimmed through the thread, but it doesn't seem to be a recurring thing - is it?