HELP! I think it's stuck!


New Member
I am using Windows 7 64 bit. I started eraser 4 days ago to erase unused disk space. Over the coarse of the first 3 days my computer was completely unusable while eraser was going. For example, if I tried to open a file or something it would take about an hour or so before it even started thinking about opening. But now, for the last day or so, I think eraser is stuck. The progress bar doesn't seem to be moving at all, and my computer is running like normal. I'm afraid to cancel the current task because I'm showing that I only have 5.95 GB of free space left. And from what I understand from reading other posts, if I cancel the task I won't get access back to all of my disk space. What should I do? How long should I let it run if it doesn't seem to be completing anything or making any more progress?
There has been a really unfortunate turn of events!!! My computer shut itself down, before eraser finished, to avoid some sort of thermal catastrophe. I guess because it's been running nonstop for four days because it's been running eraser. So now my computer only has 6.12 GB of free space! How do I get all my space back. I've read a little bit in other posts about this. Apparently I have to find some sort of root thingamajig and delete that. Obviously, I don't know what that means or how to do it. Can someone please help me with a step by step solution written so an idiot like myself can understand?
I think you are trying to do a 35 pass erase or something, 4 days seems excessive. Run one of the faster erase cycles like 1 pass as it should finish much quicker. Tere halso be a disk issue where it cannot read the drive and just gets stuck in a loop
Okay, I ran it with a 1 pass setting. It finished much quicker. However, it said "completed with errors." Also, I didn't get my disc space back. I'm only showing 9.11 GB of free space left on my whole hard drive! How do I get my disc space back?
Eraser creates a folder with random letters, if that is there, delete it..
It contains files with no extension and made of random lettering, each file is about 221mb

The error was probably about it cant access the "System Volume Information" access denied ...
You can view the error by right clicking the Task and select "View Task Log"