Help please! (Files won't delete)


New Member
There's a few files on my computer that I am unable to delete. I tried deleting them with Eraser but it told me that it was unable to delete them. I attempted to normally delete them (by right-clicking>delete) but that option is unavaliable for some reason. I even tried going into safe mode and dragging them into the recycle bin: no luck. I tried to see how big the files were but I don't even get the "properties" option (when I right-click). I ended up placing the files in an empty folder and the size of the folder is 0 bytes! It's like they don't even exist, yet the file is still there.

I've ran all sorts of anti-spyware/virus programs and they say my computer is clean. I have no idea how to get rid of them and any help would be greatly appreciated.

Also, I was just wondering.. After Eraser clears the unused space on a drive, and lets say I attempt to "bring back" the information do I see the file name of the files it erased? Or does Eraser rename the file when it erases it? I figured the file would be completely gone, but I read somewhere on the forums that the file name remains it's just empty; like the files I am having trouble deleting.
None of them worked:

KillBox says the file doesn't exist, when I browse I can spot the file but it doesn't allow me to select it. I had to type out the whole path and even than it said, "The file doesn't seem to exist" or something like that. As for Unlocker: I don't even get the "unlocker" option when I right click that file. BootDeleter gave me a brief moment of hope when I saw the "Delete on Reboot" option when I right clicked, but once I restarted my PC the file was still there :(

It's weird dude, when I leave my mouse over it for a second it tells me that the file is 2.40MB.. Yet for some reason it tells me the folder (that the file is in) is 0 bytes and contains 0 files and folders in it. How can that be?

Also.. Once I right-click it, it gives me an "open" option but it doesn't open up anything.
The problem doesn't seem to be one of the "locked" cases. I can't even open up this file (when I click to open it, nothing happens). It has an extremely LONG name and the file extension is a PDF.

Errr, I keep googling a lot of things with no results.. I am so out of ideas that I am about to take a rubber eraser and smudge it on my monitor..
toolhead - Sorry none of those helped. Have you checked your anti-virus' "Quarantine" area to see if there's been any activity lately? And it and your anti-spyware applications' scan logs?

The only thing I can think of is that you've only managed to grab the "pointer"s to a file that used to actually exist on the computer but which is gone now due to erasure, deletion or un-installation of the containing program (an orphaned file from a bad un-install, IOW).

Can you post the exact path(s) of how the files were named and where they were at originally? I've got a bunch of .pdf files on here, too, but they're all legit (associated with programs I have on this computer). Pete
Sorry to ask such a silly question but how do I get my address bar to display on the top of my folders so I can grab the complete path? I guess Explorer is different now that I've updated :(

Thanks for responding btw, appreciate the help!
Easiest way i found to delete the undelete able files is to ...
1. Create a new folder in the same directory as the folder containing the files you can not delete. (don't bother naming it yet)
2. Take all the files that you DO NOT WANT TO DELETE out of the original folder and place them in the newly created folder.
3. Delete the folder that contains the files you were not able to delete
4. Then just rename the new folder to the same name as the folder you just deleted.
5. Run eraser to wipe your recycle bin and free space
And thats it your done! :mrgreen:
I found that when I right clicked on the undelete able file, the delete command was greyed out, but when I right clicked on the folder containing the file it was not greyed out and I was able to delete the folder still containing the file.(I didn't try erasing the folder but i would think that would work also)