High frequency of "completed with errors" message


New Member
Hi everyone

So I've been using Eraser for a few days and tried to erase a couple things, like the recycle bin or SD cards; however in like 80% of the cases I get "completed with errors." in most cases it seems to have to have to do with file permissions/write protection, but I despite unticking it and it still gives me errors

Is there a known solution to this?
I read on a website that it's recommended to downgrade to Eraser 5.8 or so because the new version is allegedly inferior; opinions on this?
I'm having the same problem and have tried to give myself all permissions possible. Now I can't even erase the recycle bin without getting the "completed with errors" back. I can erase a zip drive without problems.

Any help greately appreciated.
My experience also. I am the system administrator yet find I am prevented from access to most files and cannot erase anything! This version, as far as I can tell is a waste of time. The "completed with errors" message should be changed to "nothing has been done" When I try to erase freespace I get a task list full of system file messages...what? This program can't tell the difference between freespace and system files!?

This code doesn't accomplish what is claimed, cannot provide the security promised and should be taken down until someone can rewrite it and make it effective. Over two years old! How can Heidi still tout this package, is there no QA in your organization?

Does anyone out there know how to make this abomination work as promised? Suggestions of using the earlier ver.5 make me interested in locating a download...where?

Anyone find a working security program that does what Eraser promises...and actually accomplishes it?
Going to an older app (Eraser 5.8.8.exe) apparently did solve my problem as it apparently did erase unused space in my C drive. I say apparently as the log showed "possible errors." However, it ran for some time while with Erase immediately said "not run due to permission errors."

I note the current version (as of 1-23-2014) is (wow 2620??) I'm tempted to try that.
I cannot get the lates version of Eraser to run "delete unused disk space on C:" automatically. In order to run it, I have to close the program, then run it as an admin, and it seems to work. But it never runs automatically on its own without immediately stopping with errors; is there any way to make it run automatically on a schedule?

Per previous posts, I am now trying version 5.8.8, but there must be some way to get the latest version to do this task automatically? Can someone tell me how?
Same completed with errors message. Not like that is reassuring. How can one even use this with confidence. I'm on to the next program.