How do I stop 5.8.8 so I can install 6.0?


New Member
I'm on Windows 7, Uninstall says eraser is running. I can't find it in my task list. If I invoke it and do file-exit, Uninstall still says it is running. How do I stop it?
In Eraser 5, the only thing (as far as I know) that is running in the background is the scheduler. There is an option (the exact details of which escape me, as it is some time since I have had Eraser 5 installed) not to have the scheduler start with Windows. Set that option, and restart the computer. If that doesn't work, come back, and we can do the same thing via the Windows configuration utility.

Thanks for that. Rebooting after changing scheduler option to not start at windows startup worked. Next problem follows:

Running eraser gives message 'The configuration data for this product is corrupt. Contact your support personel'.
I haven't seen this before, but it sounds like a .NET error message (I don't think that it's an error message Joel would ever write!). It is possible that your earlier problems have corrupted the Eraser 6 install. Unfortunately, issues of this kind can be a bit intractable. Try uninstalling Eraser 6 and re-installing; if that doesn't work, search this forum using the term 'brute force', and you will find several posts describing how you can pretty fully remove Eraser before re-installing. That approacg has worked for me in such problem cases.

Actually, to remove 5.8.8 would be to terminate explorer.exe (yes!) after the uninstaller has started running (i.e. once it complains that Eraser is still running.) and restart Explorer afterward.

For your 6.0 error, please post screenshots.. it would help us lots. TIA.
Here is the 'currupt' message panel. Installation doesn't proceed.


  • currupt.jpg
    9.2 KB · Views: 643
I'm sorry I misread your earlier post. This issue is clearly with the Windows Installer, not .NET.

What has probably happened is that Eraser 5 values have not been removed from the Registry. Unless Joel can pinpoint the Registry keys that are causing the problem, I'd suggest using the Registry editor to search for and manually remove all entries and values with a reference to Eraser.