I saw the existing info, but no help. Here goes....


New Member
I have used Eraser for approx. 10 years, have donated $ in support more than once (and now again, today). I love Eraser.

Now I have a problem I cannot solve.

I tried to research and solve the problem on my own - uninstall, reinstall (four times) with reboot, clearing all registry entries with a special comprehensive registry management tool, reboot twice, etc. and of course done web searches. I did not see the answer in the Forum (although I did find several references to it).

Eraser has suddenly stopped working with a right click (shell context menu). The "Eraser" word and its submenu are there, it just does not do anything when I click on it.

To save any responders their time in asking questions of me - here is a detailed list of what I have done:

It works fine when I open the app manually, searching for the file, adding it to the Schedule and running it, etc.

And no, there is nothing in the tasks list waiting to go or done. I use right click eraser every day. I am always logged in as Admin and my methods of using Eraser have not changed in approximately 10 (?) years.

I am using the most current version available on your site -, on Windows 8.1, 64. I am not quite as computer savy as many others on this site. Although I have uninstalled and re-installed the last 4 versions of the app - all with the same result (clearing the registry between each change).

I did not see the answer in the Forum, although I did say a variety of issues with the right click / shell context menu. I did take the steps that were recommended - e.g., ensuring log in as Admin, clearing tasks done or awaiting from Scheduler, it IS set to to load on startup / in the startup list in Task Manager, etc.

Again - I have used Eraser the same exact way for many years - and now - right click just stopped working - and does not work with any of the last 4 versions installed. So the issue is on my end - but where?

Will / can someone help? Thanks for your time. Happy New Year!
UPDATE - I solved the problem myself, NOT using any of the guidance already published on this site (that I could find)

Here was my solution in the event any one else can benefit:

1. I did as many instructed in other posts - turn off all shell context / right click programs, see if the problem is fixed, turning one one by one. this did not help. After shutting off every program using the shell context menu - the problem with eraser remained.
Turning off all right click / shell context programs did NOT help.
2. I therefore went back to the control panel to see what programs I installed around the time I encountered the problem with Eraser.
3. I completely uninstalled each of the 3 programs that were installed around the time the problem with Eraser developed.
4. Eraser's shell context menu / right click menu then worked!
5. I reinstalled 2 of the 3 programs, finding that in fact one of the programs interfered with Eraser.
6. Thankfully, I was able to live without that app.
7 The program that appears to have caused the problem was Total Commander File Manager.