Installation fails on Windows 7 pro 64bit


New Member
After putting up with some bugs in Eraser 5.8 surrounding the right-click contect menu in explorer I decided this morning to upgrade to v6.0.6.1376 which I downloaded from SourceForge.

During the installation all looks to be fine until the following message is displayed towards the end

"Product: Eraser -- Error 1935. An error occurred during the installation of assembly 'Microsoft.VC90.CRT,version="9.0.30729.4148",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32"'. Please refer to Help and Support for more information. HRESULT: 0x80070002. assembly interface: IAssemblyCacheItem, function: Commit, component: {3FA0170E-227C-37C7-BAC0-64691A992C81}"

I had previously uninstalled Eraser 5.8 and manually cleard all trace from the registry as well as deleting the information held in %localappdata%.

I am running a fairly clean installation of Windows 7 Professional 64 bit edition. The event logs are not showing any other errors other than the ones linked to the installation of Eracer 6 this morning. I even tried disabling my antivirus to see if that was the likely cause of the failure. During a google search, Microsoft suggested the latter as a potential fix for a similar error during the installation of Office 2010 beta.

I found one other instance of part of this error message, but no resolution, so I hope no-one objects to this new topic.

Do you have any suggestions please before I go back to Eraser 5.8.

Many thanks
I (and many others) have had the same problem. The more recent nightly builds do run on Windows 7; you can get them here.

Even though Eraser 6 is still work in progress, I would not, personally, run Eraser 5.x on Windows 7; the OS environment is very different from that of XP, which is the most recent OS on which Version 5 runs without problems.

I've now tried a variety of the nightly builds of Eraser 6.x with no success. All suggestions welcome. In the meatime if I find a solution to this bug(ette) I will post my results here.

If you do try 5.x again, you will probably find that you need to run it 'elevated'. It would be good to know how you get on.

I'm not sure what happened with your version 6 install, but the error messages made me wonder if there is an issue with your .NET Framework installation. From memory, I think that you need Version 3.5, which you can download separately and install, if the original installation is damaged in some way.

All solved!

The issue was down to a windows file, "TrustedInstaller.exe", which for some reason was missing and therefore the service wouldn't start. It seems that Avast antivirus which I was running can remove this thinking it is a suspicious file.

After booting the Windows 7 DVD into repair mode I restored "TrustedInstaller.exe" from a hidden backup of the file which I'd found on my PC. I put the file into its location "C:\Windows\Servicing". After a reboot I set the associated "Trusted Installer" service to manual and then started it up in order to test it. Thankfully it worked.

All happy now and Eraser 6.x is now installed. :mrgreen:
Thank you for this. Another one to add to the list of ways 'helpful' applications make life difficult for us!

Did Avast report, or at least log, what it had done?

Yes, the first thing that struck me when you psoted the error was that it was a Windows Installer problem which doesn't seem to be caused by Eraser directly. The fact that TRustedInstaller is missing would be one of the causes, yes.
I suddenly remembered a similar issue when I was testing an early beta of Windows 7. Luckily I keep detailed records of all my testing. So this got me checking the services that were running. On doing this it was glaringly obvious that something was wrong with the TrustedInstaller service. When TrustedInstaller still wouldn't start I found that the exe was missing. A quick google found that Avast has a habit of misidentifying TrustedInstaller as unkown malware and removes it without clearly logging the event.

Avast didn't report removal of TrustedInstaller. Well that is not strictly true, it apparently logs it as an unknown heuristic and in theory gives you a pop-up box asking if you want to remove the unknown file. As i'm not the only user of this PC I can't confirm for certain whether this happened or whether the file was automatically removed as appears to sometimes be the case.

I now have a backup of TrustedInstaller.exe just in case a similar issue crops up again. Who knows what would have happened if this issue had occured to a non-technical user. An unneccessary rebuild of their PC most likely.

I've reported my findings back to Avast. Avast have responded saying that the issue will be resolved in a future update.

Anyway, i'm glad it's resolved and hope this posting has been or will be of help to others.

Thanks for the support, and keep up the excellent work on Eraser.

Kind regards