Installation Issues


New Member
I'm not exactly sure what's going on with the program, but I've tried installing multiple versions of eraser (stable version 6, 5.8) and so far have been unable to complete an installation. The version 6 installation got to the end before rolling back, giving me the following error:

An error occurred during the installation of assembly 'Microsoft.WC90.CRT,version="9.0.30729.4148",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86",type="win32'". Please refer to Help and Support for more information. HRESULT: 0x80070422.

After receiving this error I tried installing the 5.8 version. Sure enough it installed correctly, however when I attempt to run it, I receive another error message:

Unable to execute file:
C:\Program Files\Eraser\eraser.exe

CreateProcess failed; code 14001.
The application has failed to start because its side-by-side configuration is incorrect. Please see application event log for more detail.

Following which I went to the event log, which says:

Activation context generation failed for "C:\Program Files\Eraser\eraser.exe". Dependent Assembly Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.30729.4148" could not be found.

If you can help in any way it would be greatly appreciated.
Did you install the latest versions from SourceForge or did you get it from other download sites? The newest versions on SF fixes this.

Also, since Windows Installer complains about the installation of the side-by-side assembly cache, it is probable that your Windows install is corrupted, you may like to consider reinstalling Windows one of these days.