Locked file warning


New Member
I asked this question earlier when using version 5.8.
I'm now trying version 5.82 and seem to have the same problem, namely.

When erasing files I get a message informing me that there are locked files which can be deleted at boot time. So far so good.

What I would like to do is to switch off this message.

Using the settings "Enable resolving of file locking" and "Ask user" in the general preferences this should be possible?

So far I have tried every combination of these two settings and still get the message. At the moment I have both settings deselected and still get the message asking me if I want the file to be deleted at boot time.

It's not a major problem just irritating.

Any help or ideas appreciated.

Well so far this post has been read over 200 times without comment.
Obviously nobody has any idea how the message asking if a locked file should be erased at next startup can be avoided, or nobody has been having the same problems I have had.

Whatever. It looks as though I will have to uninstall 5.8.2 and reinstall 5.7 to avoid this (admittedly usefull) "annoying" message.

Thanks for the help :wink:
jackjack said:
Post it as a bug to the suggestions page.

Out of curiosity, what is the file in question?

Wow, a reply!

Maybe I will.

It happens mainly when I delete my temporary internet files so it will be index.dat that is causing the problem in this case.

However, I have had the problem with other directories as well. In the older versions of Eraser the files were not deleted and a summary of the undeleted files was shown.

I realise for some people that this information is maybe important, for me its just annoying that when I delete adirectory I have to keep clicking away a message box telling me that files are locked. Any method of supressing this message would be, in my opinion, an improvement.

I have decided to uninstall 5.82 and reinstall 5.7 in the hope that my problem/annoyance may be solved at a later date.

I still think that Eraser is an excellent tool.
Version 5.84

It seems as if my problem has been solved.

Version 5.84 behaves the way I expected the previous versions to behave and the annoying messages are gone!

Thanks :D